Mini LCd stopped working once OS has booted

Yeah i was a little surprised it worked, it did make the screen play the first time boot animation and sound, stayed blank for 5sec and then was good to go, i dropped the “broken” OS card back in and it did the same thing, could it be as simple as needing to set it to that first boot state and then its good?

Bellow is the git I just setup for the code gen stuff, i just snapped it out of my main project so it may not be 100%, it does build and it all seems to work. The project file setup is a bit janky but it should get you started, not many comments right now but not much code and it should be simple to follow, ill update it soon with comments and a few other more advanced bits.

Tiba3195/netcore2cpp: netcore3.1 hosting and native code generator (

@duwudi - I’ve experience similar to Justin. The OLED stops displaying anything (except for the [4] animation during shutdown or boot-up). Then I boot with a different microSD with a different install of pitopOS and the OLED starts working again. – Then I return to the previous microSD and the OLED continues to work.

It’s a weird phenomenon because you would think that when the OLED stops working because of software, shutting down and rebooting would reset the OLED, but it doesn’t. So booting first from a microSD with the pitopOS that still needs to “initialize” seems to “reinitialize” the OLED and then going back to the previous microSD keeps the OLED working normally.

Almost like whatever is causing teh OLED to go blank is written to memory on the RPi and the only solution is to reboot with a fresh install of pitopOS and then go back to the other microSD to continue working normally.

@Justin – I totally get the frustration because I’ve experienced the same behavior and there’s some comfort in knowing others are too and that it’s just not me going crazy alone. :grinning:

I just got my Pi-Top 4 today and I’m having this problem, but flashing the OS doesn’t seem to help. The screen was working perfectly up till I was in the middle of trying the Data Analysis exercise on Further.

What I’m seeing: During boot, the “4” animation appears, and when the Pi is ready, it goes black and remains black. During shutdown, it animates, briefly shows the battery status, then turns off. I also get the battery status for a second after I plug the power in while the Pi is off.

I’ve tried reflashing the SD card that came with the kit, and flashed another SD card I had handy, but in both cases the result is the same.

Hi all - can everyone try using the latest OS image on the website, and let me know if that helps? We made a number of changes under the hood in this area that may have helped…

I just did and it doesn’t seem to be helping. I flashed the SD card with the latest image and booted, but once it got past the “[4]” animation the screen went dark (where during the first install it was showing me the IP address).

FWIW I see the same issue. I set up PI-TOP 4 DIY for first time today. Installed the latest 12-22-20 OS from the web site. Also had a message that the firmware needed to be updated, clicked on update it, saw nothing happen. Restarted the PI-TOP 4, got the message that the firmware needed to be updated. Clicked on update and then got a message that is was updating, then it was updated, and then I needed to restart, which I did. I haven’t see anything on the OLED display except the battery charging icon, and the “[4]” animation when booting, and ending up with a blank screen. I tried the ps -ef | grep python command and saw that /usr/lib/pt-sys-oled/pt-sys-oled was running.

I have this same issue. I used a freshly install pi-top OS, the last as today. The first time I tried it worked, but after clicking in the firmaware update the oled stopped working. I updater the eeprom again to check, but the issue persists. Seems to be a problem with the latest firmware update.

Using an older pi-top OS from an older image made this works again. I installed the older SD as @Tom-B said worked. Use older SD with older OS image, and then switch to the new one. IDK what the problem can be. Maybe pi-top can provide us some older OS images to workaround this.

1 Like

Same Problem here too.

Fresh Install with OS Image “”. Clean Install and Reboot afterwards…

OLED Display remains Black.

Some Debugging Informations:

pi@pi-top:~ $ ps -ef | grep python | grep pt-sys-oled
root       876     1  3 20:29 ?        00:00:18 /usr/bin/python3 /usr/lib/pt-sys-oled/pt-sys-oled
pi@pi-top:~ $ pi-top  devices
HUB ==================================================================================================================
pi-top [4] (v5.4)
PERIPHERALS ==========================================================================================================
[   ] pi-top Touchscreen 
[   ] pi-top Keyboard 
[   ] pi-topPULSE 
[   ] pi-topSPEAKER (v1) - Left channel 
[   ] pi-topSPEAKER (v1) - Right channel 
[   ] pi-topSPEAKER (v1) - Mono 
[   ] pi-topSPEAKER (v2) 
pi@pi-top:~ $ pi-top oled draw "hallo"
Press Ctrl + C to exit.
# Nothing Changes on OLED Display!! OLED Display still remains Black.
pi@pi-top:~ $ cat /etc/os-release 
PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION="10 (buster)"
pi@pi-top:~ $ sudo apt update
OK:1 sirius InRelease                             
OK:2 buster InRelease                                                 
OK:3 buster InRelease                                              
OK:4 stable InRelease                    
Paketlisten werden gelesen... Fertig      
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Alle Pakete sind aktuell.
pi@pi-top:~ $ sudo apt upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
pi@pi-top:~ $ vcgencmd bootloader_version
Sep 10 2019 10:41:50
version f626c772b15ba1b7e0532a8d50a761b3ccbdf3bb (release)
timestamp 1568112110
update-time 0
capabilities 0x00000000
pi@pi-top:~ $ date -R
Sun, 03 Jan 2021 20:47:43 +0100

Thanks everyone for the detailed feedback, we are looking into this issue as a priority - apologies for the inconvenience caused and we’ll get back to you ASAP with a solution :+1:

If adding some info helps, after using the older OS Image (I think is 2020-05 or something like that) the screen worked even with the new OS image. But, the VNC info is missing in the screen while still being able to connect via VNC.

Hi Duwudi
Any news or ETA on this problem. I have the same issue. the display was working until I tried some of the sample code. one of the examples failed - I think it was the last one. Since then a reboot, reflash, new flash card has failed to bring back anything on the display except the initial boot sequence

@Graham yes, we know what the problem is now - I need to check if the team has rolled out the patch or not. When they come online today I’ll get an ETA, thanks for your patience!

Hi all, we have been doing quite a big refactor of the OLED codebase recently to make it significantly easier and more intuitive for people to interact with - this means we will be slightly slower than usual in rolling out the patch to resolve the bug as the test cycle is compounded by the need to test the entirety of the new system. We hope to have this out soon and we thank you for your patience and feedback :+1:

Hi everyone, not sure if you’ve seen yet but we’ve rolled out an update that should hopefully fix this (with lots of other added improvements) - you can see the update post here :+1:

@duwudi Thanks for the update. It seems to work as expected.


You can check the logs, forgot the location (maybe @Supernovali can inform) , this is really handy at diagnosing issues with scripts when using the OLED.

I only have this issue if my code has errors in it and hard exits (crashes) locking up the use of the OLED.

Looking at the logs will tell you the exact problem down to what line of your code caused the issue.

If the OLED works on a fresh install of the OLED then it’s more likely an issue from your code that caused it

I am having problems with my oled screen of the pi-top 4 since it does not show any type of information even when I turn it on for the first time, I do not know what is happening since I am installing the PI-TOP OS system.

Hi @luisherrera
Can you tell us which version of pi-top OS you’re using? you can find the version by going into the start menu, Help > About pi-top OS

I am using the latest version of this operating system, the mini screen at the time of loading has to turn on showing the battery status, in my case it does not.