Mini LCd stopped working once OS has booted

If adding some info helps, after using the older OS Image (I think is 2020-05 or something like that) the screen worked even with the new OS image. But, the VNC info is missing in the screen while still being able to connect via VNC.

Hi Duwudi
Any news or ETA on this problem. I have the same issue. the display was working until I tried some of the sample code. one of the examples failed - I think it was the last one. Since then a reboot, reflash, new flash card has failed to bring back anything on the display except the initial boot sequence

@Graham yes, we know what the problem is now - I need to check if the team has rolled out the patch or not. When they come online today I’ll get an ETA, thanks for your patience!

Hi all, we have been doing quite a big refactor of the OLED codebase recently to make it significantly easier and more intuitive for people to interact with - this means we will be slightly slower than usual in rolling out the patch to resolve the bug as the test cycle is compounded by the need to test the entirety of the new system. We hope to have this out soon and we thank you for your patience and feedback :+1:

Hi everyone, not sure if you’ve seen yet but we’ve rolled out an update that should hopefully fix this (with lots of other added improvements) - you can see the update post here :+1:

@duwudi Thanks for the update. It seems to work as expected.


You can check the logs, forgot the location (maybe @Supernovali can inform) , this is really handy at diagnosing issues with scripts when using the OLED.

I only have this issue if my code has errors in it and hard exits (crashes) locking up the use of the OLED.

Looking at the logs will tell you the exact problem down to what line of your code caused the issue.

If the OLED works on a fresh install of the OLED then it’s more likely an issue from your code that caused it

I am having problems with my oled screen of the pi-top 4 since it does not show any type of information even when I turn it on for the first time, I do not know what is happening since I am installing the PI-TOP OS system.

Hi @luisherrera
Can you tell us which version of pi-top OS you’re using? you can find the version by going into the start menu, Help > About pi-top OS

I am using the latest version of this operating system, the mini screen at the time of loading has to turn on showing the battery status, in my case it does not.