Autostart VNC Server not working

I successfully installed the VNC Server in pi-top OS.
Now I have the entry for the VNC Server in the menu. When I started it for the first time it complained that the standard port for VNC server is already used on this machine. So I entered another port number and it works now whenever I start the Server manually via the menu.
But on a “normal” Raspbry Pi OS the VNC server is started automatically at startup. Not on the pi-top OS. Propably because of the non-standard port number.

Could you please help me to autostart VNC server in pi-top OS.

Many thanks
Martin Klein

can i ask how you installed it and also which VNC?

RealVNC is installed by default and is a free educational licence with no restrictions, on Raspberry Pi. this is activated via

  • Menu > Prefferences > Raspberry Pi Configuration
  • then under the Interfaces tab select enable for VNC.
  • Click OK

This starts up RealVNC server automatically, even on a reboot.

If this does not work, you may hate this suggestion, try with a fresh install of pi-topOS from here and follow the steps above

1 Like

Many thanks for your reply.
I installed VNC with: sudo apt-get install realvnc-vnc-server
And it worked when started via the menu but no autostart.

Well - I worked through your suggestion and started from scratch - and it worked !

VNC autostarts now !
Many thanks and kind regards
Martin Klein

1 Like