Bluetooth keyboard performance

I bought a Logitech Bluetooth K380 keyboard recently for my pi top 4 and was disappointed with the performance. It was virtually unworkable as the keys constant repeated. I adjusted keyboard settings in pi-top OS for key repeat delay etc. but it didn’t work.
After speaking to a friend he suggested re-flashing the OS as he’s seen other OS related issues that had been fixed by a re-flash, and I’m pleased to say it worked.

My pi-top OS was up to date as far as it could be so I’m not sure why it’s now working, but very pleased it is.

I’m not part of the pi-top team, but from what I’ve been told this morning, they may be busy with meetings and such this week. However, it really could be many things. But, SD cards were never really intended to run operating systems. They are pretty slow, and because operating systems tend to perform something called “page swaps,” they can wear down prematurely. Could also be SD card quality.

Either way, good to hear that you were able to get it running. Now, make sure you run backups frequently. I also recommend making your boot drive an external one if you can and it’s practical. Makes for a faster experience. :slight_smile:

Interesting hypothesis!

It could also be due to a load of Bluetooth driver changes by Raspberry Pi OS recently - apparently, they’ve standardized with the Debian ones now. It was quite a big change so it could have been due to some instability introduced there - reflashing is often just the easiest way of fixing problems like that

That’s interesting to hear about the Bluetooth driver upgrades in the Raspbian distro.
The re-flash was pretty painless, so a good option for the future. I’ve scripted my custom package installs, and saved project folders to a remote drive so well prepared for the future!

1 Like