Bug Report: Built-in Speaker Volume Control

Hey,

Built-in speaker volume control isn’t working on Raspbian OS. I’ll try booting into my Sirius OS and test it there but I’m only getting about a quarter of the loudness that I remember getting in Sirius. This includes the mute from the system tray.

Update: volume control does work in Sirius OS

Raspbian’s default device is HDMI, not AV Jack. Please change it via the volume control icon in the system tray, and adjust the volume accordingly.

Hope this solves your issue!

The issue isn’t that HDMI volume control doesn’t work, it’s that the built-in speaker works, but volume control doesn’t work. Using the system tray to adjust volume, or even mute doesn’t work. I’m suspecting a driver issue, but it works fine in Serious.

This feature would be useful in conjunction with the pi-top display while on the go so that users can mute or change volume of the built in speaker as to not bother the people around. I can change the output device and with an HDMI audio output, muting and changing volume does indeed work, just not for the pi-top [4] built in speaker.

:wink:

Screenshot%20from%202021-02-08%2010-15-35

I presume that we’re talking about pi-top [4]? The pi-top [4]'s onboard speaker is routed directly - there is no additional hardware or software controlling this, so I am unsure how that is possible. @duwudi - any ideas?

hey @Supernovali !

I’m using a pi-top [4] with an up to date version of Raspberry Pi OS, and can’t replicate the issue you’re describing: I’m able to control the speaker’s volume using the system tray volume icon. I did have to, as @pi-topMIKE said, change the output device from HDMI to AV Jack (by right clicking the system tray volume icon), but apparently you already did that.

Maybe checking the journal/logs while trying to control the volume can help to determine the issue

Sorry, yes, for the [4]. So, I do have some volume control… depending on the application and whether it has it’s own volume control as well (so this isn’t a driver issue).

On another note, I have another issue with the audio. It seems that the audio output isn’t as high as it is in Sirius OS. I’m going to use my oscilliscope and record the peak-peak voltage of the audio output and represent it here between the two OS’es as well. Watch for the update.

Edit: I also decided to do an update as from when I made this post there was one. Idk what the change was, but I have volume control to the builtin speaker now on the some apps that I didn’t before. But it is significantly quieter still than Sirius OS. I’ll post a video now… hold on :grimacing:

Ok, pardon the mess, I’m re-arranging my work space, but here is the difference. The peak loudness is taken from about a foot away on the volume measurements.


Videos:
Raspbian OS - https://youtu.be/Xbd8RB-4awk
Sirius OS - https://youtu.be/0WrGopRMkwg


Measured Loudness from ~1ft (includes clicks to take screenshots)

Average Background - Avg: 44db

Raspbian OS - Avg: 50db

Sirius OS - Avg: 64db

Can you try digging into the PulseAudio settings? And maybe play some sample audio through that.

Raspberry Pi recently switched to PulseAudio which has caused some issues elsewhere too - the main one is the “crackle” noise every time a VNC session is started or screen resolution changes. We’re still trying to look into how to fix this

Ahh, yeah, I’ll give that a shot. I did notice that on the Sirius OS, but haven’t really noticed it on Raspbian. I’ll see what I can come up with.

Been a busier than usual week for me.

Edit: I just turned it on for the first time in a few days, and now I’m getting “No audio devices found” when attempting to right click on the system tray volume icon. (seems to have been a one time deal? Is working now)