Connecting a RPI Pico with LED Matrix (MAX7219)

Hello dear community!

Here’s the issue I’m encountering with:

Trying to connect the Pico with the LED Matrix as a screen for the clock there’s a situation where I need your help. When the Pico and the screen were connected with this accordance

  1. VCC <-> Pin 40 (VBUS)
  2. GND <-> GND
  3. DIN <-> Pin 5 (GP3)
  4. CS <-> Pin 7 (GP5)
  5. CLK <->Pin 4 (GP2)

It was possible to turn the screen on, actually using the ready code from the net, after the GPT helped to generate a code which to fit my own requirements. There was a strange point also, when I run the custom code first it didn’t show anything it worked only after the working code from the github has been run and stopped, then it was possible to run the custom code and it worked as expected.

So for now some of the pins (Pin 4 the same GP2) in the pico are busy and I’m trying to turn on the screen but can not see any reaction on it. Now it’s connected with this accordance:

  1. VCC <-> Pin 1 (VBUS)
  2. GND <-> GND
  3. DIN <-> Pin 10 (GP7)
  4. CS <-> Pin 7 (GP5)
  5. CLK <->Pin 9 (GP6)

So the screen does not print anything on it, like it was in the scenario described above. The code itself behaves like the code was run and seems the connections are correct.

What can be wrong here, where to look? Would appreciate any advice from the experts surfing here))