Connection Problems

I’m trying to run through the tutorials to get a feel for coding for the device. I keep getting an error when I try to do the motor or servo tutorial. The error says there was a problem communicating with your device.

  • Device is freshly flashed with the latest OS
  • Firmware was upgraded
  • I tried different hardware ports
  • I ran the diagnostics, the further app was able to connect to the device. (and the camera demo ran fine)

any ideas?

@Ltrain it looks like that Further tutorial hasn’t been ported over to the new style yet, and since the camera tutorial worked perhaps a bug has been introduced for the old style challenges - I’ll get the team to look into it. In the meantime, you can just copy that code into another IDE or do some of the other robotics challenges we have available :+1:

Indeed there was a problem with the old format. I’ve updated these to the new format and you should now be able to connect. Thanks for pointing that out!

Ok I’lll give that a try. I’m not a python guy(or even a Linux guy) can I just run any ide with a remote target against the PI?

Or should I run that code using one of the IDes on the device?

Ah looks like I just edit a local file and execute the interpreter against the file. Easy enough.

That worked, I was able to execute the code locally and got the robot to drive across the floor. Now I just need to figure out how to mount the pi-top remotely so I can execute the script wirelessly. But this was a successful water through the pipes test.

I’m really enjoying this, it’s a great break from my usual grind!

confirmed this works Mark, thx.

@Ltrain glad you got it working! If you use Further from a browser on any other computer/laptop you can use it wirelessly :+1:

That’s exactly what I did. It makes for a pretty easy remote execution model without me having to use SSH and mount drives. (I’m sure I’ll get to that later)

Also being able to get the IP address via the LCD module is pretty handy.

1 Like