Crankshaft and Pi-Top

I’m using Pi-top case and Pi-top display.
When I use Crankshaft OS and Pi-top together, it boots up fine, but reboots after 10 seconds and goes to loop.
When I’m using Crankshaft without the Pi-top case it works OK.
Any idea what might be causing this?
I don’t have time to get the debug log because it starts to reboot…

Hi Veks,
Sorry to hear about the issues with your pi-top. It sounds to me as though you may have bought a DIY, is that correct? With your DIY, please make sure that the metal ribbon cable is firmly inserted into the Mezzanine PCB. In addition, please make sure that the USB Plug is also inserted into the bottom left USB Slot of the Raspberry Pi.

It’s both of those together that may automatically shut down your Raspberry Pi. If one or the other isn’t connected, the pi-top will think your Raspberry Pi has gone into a fail-state or has a short-circuit somewhere and will cut off power to prevent further damage.

Let me know if you’ve checked both of those things and we can think of next steps.
kind regards

Hm, I have tried now to boot Pi-top OS too, and I get the same problem.
I’m having a separate discussion with your team via e-mail, and team from the retailer from whom I’ve bought Pi-top.
It seems that there might be a problem with that USB plug part so I need to send it for repair or a new one…

hm, it seems that actually Pi-top works OK.
But when I try to run OpenAuto Pro or Crankshaft I get the error that there is undervoltage, low voltage.
And I’m trying both, running via power supply and directly from integrated battery… And it’s the same…

Did that situation get resolved? Somehow, those other OSs are managing to eat more power than they ought to, is my idea #1. Use the top command to see if there’s a server process eating all your CPU. That’s no a very good idea, because the Pi itself ought to be able to run full blast on all cores. I don’t think I’ve tried that on a pi-top, though. Sigh. The other issue could be the alternative OS not interfacing with the low-power indication proprietary stuff in the Pi. Do those other systems explicitly support the Pi 4?