Error burning pitopOS

When I try to burn the pitopOS to my SD card using the standard RPI imager, it looks like a successful burn but generates an error at the end that says: “error extracting archive: file size cannot be restored”
When I try to boot from that SD I get all sorts of errors. I’ve tried redownloading it. I’ve tried a second 128gb card. Always get the same error.

Burning from W10. I can’t figure it out. Any ideas?

@jojemar – First of all, welcome to the pi-top forums. Glad to have you join us all here.

Are you flashing the boot microSD from the ZIP file or are you extracting the .img file from the ZIP first? Programs will work with the file still compressed, but if you haven’t tried extracting the .img file from the ZIP file first then flashing the microSD, I would give that I try.

I flashed new microSDs for my pi-top[4]s with the newest pi-topOS just a day ago and it worked great after extracting the .img file first for me.

Extract the img file out of the zip first and flash using the img file

I’m dumb!

Okay, now when I power on, I get the [4] on the OLED, but my monitor won’t turn on and then the OLED displays two strange icons, one with an arrow pointing to the other, then the power light goes from green to orange.

It looks like it’s saying to insert an SD, but I have an SD in… tried with multiple SDs. I tried Manjaro distro and it booted most of the way up before turning off… saw the Manjaro logo and then monitor switched back over to HDMI2.

The full boot sequence for pi-topOS

  • Power on
  • expand drive/card
  • reboot
  • start up
  • on boarding process.

Raspberry Pi OS is similar and is the only 2 OS’s I have used on pitop hardware due to support/SDK compatibility.

Not sure why your having this issue, have you tried using a different SD card or drive?

Making progress, switched cards again and now it does the full boot and displays an animated PITOP on the OLED. Still can’t get it to output to my monitor. Just the brief flash from when I tried Manjaro which led me to believe it wasn’t physical.

Trying from the raw board and same result. Maybe it’s a defect on the Pi? Or the cable? I lovehate technology.

Can’t be the cable. When I misburned the pi image by not extracting the zip, the pi was able to show the boot errors just fine on the monitor. If I misburn the SD and do it again again the boot failure of the pi is displayed clearly on my monitor.

  1. What monitor are you using? And what resolution?
  2. What HDMI cable are you using?
  3. You have to boot up with the monitor attached, or you can use the HDMI reset option in the OLED’s settings menu to re-initialise the HDMI output

@jojemar You’ll see that icon on the OLED as you’re not using pi-top OS. This is because pi-topOS already has the drivers installed to allow the Raspberry pi to talk to the pi-top hardware. If you use a different OS, then the pi-top hardware won’t be able to communicate with the Raspberry Pi and will just assume that there’s no SD Card in the Raspberry Pi.

It won’t affect your usage of the pi-top and you can try installing the drivers afterwards. The instructions are here.

I got it… apparently I wasn’t giving it enough time for that first cycle… lot longer than I thought.