Error running the "First Challenge"


Few hours ago I received my Pi Top[4] and it is an awesome device. Thanks for building something so cool.

For getting familiar with it, I started with the “First Challenge” where I’ll write a small program that displays a rocket into the screen.

I had some issues that I have already solved (first thing I did, was to update and restart)

  • pitop was not installed in the system. Since I’m familiar with Python, I created a folder for my projects and created a virtual environment. After activating the environment, I installed pitop with pip install pitop
  • The script complained then about the library I installed it with sudo apt install libatlas-base-dev
  • Then I got the following error:
Traceback (most recent call last):
  File "", line 8, in <module>
    miniscreen = Miniscreen()
  File "/home/pi/Projects/venv/lib/python3.7/site-packages/pitop/miniscreen/", line 22, in __init__
    super(Miniscreen, self).__init__()
  File "/home/pi/Projects/venv/lib/python3.7/site-packages/pitop/miniscreen/oled/", line 37, in __init__
    self.__controller = OledDeviceController(self._redraw_last_image)
  File "/home/pi/Projects/venv/lib/python3.7/site-packages/pitop/miniscreen/oled/core/", line 37, in __init__
    self.__spi_bus = self.__get_spi_bus_from_ptdm()
  File "/home/pi/Projects/venv/lib/python3.7/site-packages/pitop/miniscreen/oled/core/", line 92, in __get_spi_bus_from_ptdm
    response = request_client.send_message(message)
  File "/home/pi/Projects/venv/lib/python3.7/site-packages/pitopcommon/", line 388, in send_message
    raise Exception(f"pt-device-manager reported an error ({response_object.message_id_name()})")
Exception: pt-device-manager reported an error (RSP_ERR_SERVER)
> pt-devices
Devices and peripherals handled by pt-device-manager:
OS release: 5.10.17-v7l+
Host device is pi-top [4]
> pi-top devices
HUB =========================================================================================================================================================================
pi-top [4] (v3.0)
PERIPHERALS =================================================================================================================================================================
[   ] pi-top [4] Foundation Plate 
[   ] pi-top [4] Expansion Plate 
[   ] pi-top Touchscreen 
[   ] pi-top Keyboard 
[   ] pi-topPULSE 
[   ] pi-topSPEAKER (v1) - Left channel 
[   ] pi-topSPEAKER (v1) - Mono 
[   ] pi-topSPEAKER (v1) - Right channel 
[   ] pi-topSPEAKER (v2) 
[   ] pi-topPROTO+
> pi-top oled display "Hello World!"
Error on pt-device-manager reported an error (RSP_ERR_SERVER)

It seems that there is a problem connecting or detecting the miniscreen. However, the mini screen is showing the battery level and if I press the arrows it shows different information (VNC, Wifi, LAN…)

Any ideas about how to continue?

Update: After reboot, the mini display shows the [4] logo display, later, an icon that I read as “Insert the SD Card” and then it turns off. The Pi-Top is working, though, and I can connect via SSH, VNC and run code.


After downloading and flashing again Pi-Top OS the mini screen works as expected.

@mmartinortiz good to hear you solved the problem, in any case, thanks for the detailed report - if you find any other issues this format will help us diagnose the problem faster! :+1: