Expansion Plate USB


I have 2 questions below:

I bought pi-top4 diy & robotics kit yesterday.(incl. expansion plate)
I have tested servomotor, drive motor, camera and sensors.
Almost sensors are worked well in python SDK.

But, I found usb-camera doesnt work using expansion plates usb port. After I connected to pi-top4 usb port, then camera worked well.
All 2 ports from expansion plate are not working properly. I did re-assembled several time to check usb connection between rbp4 and pi-top4. Also usb ports are not working.

One more strange thing is that my expasion plate do not have usb-c pd port located middle of 2 usb ports which is different from product webpages : Expansion Plate Explained! (pi-top.com)

Is it different expansion plate model? How can I check right expansion plate with my robotics kit and pi-top4 board?

In python SDK, there is IMU example. Is it also optional sensor? When I run IMU example, “This Expansion Plate doesn`t have an IMU” message is printes with Exception.

I think the new ones do not have any IMU; however, no one has yet confirmed this. I certainly have not been able to access it.
I found that the best thing to do is to download opencv and work with that.

open a terminal and put in the command:
upgrade pip:
pip install pip -U
this next bit is needed before you install opencv
sudo apt-get install libgtk2.0-dev and pkg-config
pip install opencv-contrib-python

Your camera will be accessed in python with
import cv2
I hope that helps.

Thank you for reply.

I think that OpenCV and SW are not problems. I have experienced more than 15 years in opencv uses.

When I enter “lsusb” in terminal, usb port of expansion plate don`t recognize any devices not only cameras but also usb receiver and others.

As I mentioned before, the camera worked well on pi-top usb directly. All usb from expansion plate are problem. That`s why I would like to check two different types of expansion plates are exactly same usb circuit. Or How can I check if the hardware is OK or not?

Looking forward to your further support!


It is an obvious question, but have you checked the plate with any grove sensors or a multimeter to see if you are getting power to the pins?


Sorry for late reply.

I connected usb powered led, then led worked well. I think power is not an issue.

No bother,

If it is getting power, then there might be a software issue.
I am going to assume that the firmware is up to date etc.,
Can I look at the code you are using? Perhaps there is something there.