Fan always at full speed

my Pi-top 4 DIY arrived last week and I put it together and used pi-topOS Bullseye. Using j2 and with the CPU at 35 degrees and not plugged in the fan is running at full speed. Any ideas?

PitopOS 3.0-9
Firmware 5.4
Hardware 9

bump, I also opened a ticket a few days ago and have seen no response.

bump, just wanted to follow up on this again

I know a deep secret here. You can open up the pi-top four and find where the fan is connected via a connector. If you unplug it and plug it into the vacant socket of the same kind that is nearby, you get full control of the fan. I’ve never looked up the programming for this, though. The 4B probably will overheat and throttle unless you do get the fan turning, because of the closed case.

Yes, that’s what I am doing for now, but would prefer to have the option to have out of box functionality work.