Fan running at full speed

I’ve just installed the pi-top 4. Downloaded pi-topOS Sirius and tried it on a seperate Rpi. Things worked as expected and the Linux updates worked flawlessly.

Then I moved the sdcard to the pi-top 4 and booted. I got a message about required firmware-updates which I did. (I expect some software running on the hub?) Raspberry pi is booting, ssh works, using the external fhd display works… all good. BUT I have the feeling that the cooling fan is going full speed. That is no good because the noise level is just too high. I’d need advise on what to do. Can I check if the hub is working as expected? Or is it just a simple (known) issue that can be instantly fixed?

Thank you so much

@wedge First, welcome to the forum.

Assuming, just a bit, that you are using a DIY Edition of the pi-top4, I think it would be helpful to know which connector you used for the fan connection.

The left connector (labeled “For RPi Connect”) in the above image is when using the the pi-top4 OS. The right connect (J8) is for other operating systems, etc.

I’m not sure what else it would be if you have this connected properly, but thought I’d throw that out there just in case.

Hey Tom!

First the assumtion is right. My pitop is DIY edition. However I connected the fan an the left connector following the assembly video. Can you confirm that after booting the fan should be close to silent? CPU temp is reading 29 degrees C and the fan is blowing.

2nd question: should the voltage at the fan show some pwm? Can I measure that using a scope?

I have two pi-top{4] DIYs and they both operate silently. I cannot hear the fan in either of them. Not sure about putting it on a scope. Someone with more electronics knowledge than me hopefully will chime in to help with some ideas.

Someone with more electronics knowledge than me hopefully will
chime in to help with some ideas.

That we be great. I wonder I could have made a mistake during assembly. However as far as I understand the fan is under control of the hub and because of that independant of the pi itself, right? Fan control is routed over that tiny connector with the silver srew underneath?

I’ll check for additional ideas regularly :slight_smile:

I just wanted to report what I came up with: because the 100% fan did not slow down I decided to do it the hard way. I removed the pi connector on the pcb and fan and soldered the wires directly to the board through 3 diodes. The pi-top connector is left unchanged so if there will be any solution found I can try to get a fan that fits and connect it instead.

Noise is still more than my scope, but with a little good will, acceptable. Core Temperature barely rises, but I think it will be a good advice to monitor it regularly espacially during charging.

I have had my Pi-top[4] since last Christmas 2020. it started running with the fan at full speed around october november 2021 time-frame. my pi-top was not a DIY version

Welcome to the forum @dealkids

Do both of you have your firmware up to date? To check the version run the pi-top devices command. into your terminal. It should be v5.4 currently.

Otherwise @dealkids your fan might have deteriorated as they unfortunately do but if yours was ordered from Christmas 2020 then contact on our support form and I can get a replacement sent to you.

@wedge Do you know if yours was charging the whole time whilst the fan was running?