Install pi-top Device Manager on Raspbian

Hi
I have a Pi-Top (original laptop version) that I bought from CPC Farnell just a few months ago. It was working well.

Today I changed the Raspberry Pi for a faster one and I thought I had been careful removing the GPIO cable. However, when it boots up, it gets to the Raspbian desktop screen (I am just using Raspbian Buster (after doing “sudo apt-get install pt-device-manager”)) it then immediately shuts down again. If I disable SPI in raspi-config, it boots up into the desktop normally. It’s usable but of course I can’t use the speaker or adjust the screen brightness.

I swapped back the original Raspberry Pi, and I am getting the same symptoms.

My diagnosis is that, either the GPIO cable is damaged somehow (I can’t see any obvious damage), or the hub has stopped working.

If you could send me a spare GPIO cable, that would be great, and hopefully that will fix it.

Thanks

Steve

Oh, it’s not a hardware problem, after all. I tried Pi-Top OS in the Pi and it booted up and worked properly. There might be some conflict with the latest (February 2020) version of Raspbian and pt-device-manager.

Hi Steven,
I think what’s happened is that the pt-device-manager that you’ve install is not the current version that’s available on pi-topOS, It’s a version hosted by Raspbian that’s unfortunately a few years old. I’m guessing that the version you’ve downloaded isn’t compatible with the version of Rasbian you have downloaded.

The easiest thing to do would be to download pi-topOS to get all the compatibility with the pi-top Hardware. Though if you do want to keep Raspbian, then you can also try running
sudo apt install pt-devices
I’ve just tried it with my pi-topCEED and it did manage to install my pi-topSpeaker_v2 successfully (though I don’t have access to the volume controls without pi-topOS) but I’m in lockdown without a pi-top1!

Let us know if it works for your pi-top1!
-Rez

PS I’ve also changed the title of your topic from Replacement GPIO cable needed, and moved it into the pi-topOS section so it’s easier for other users to find

1 Like

Could you help at all wwth a Speaker Mk 1 no sound issue using a Pi Top CEED - original - and the new Sirius OS?
I can get speaker sound immediately after I flash the SD card but then it stops working!!

Hi Rez,
Was this with a RPi3B+ or a RPi4?
Thanks in advance!

pi-topTEAM, can you please clarify a bit? You say “I don’t have access to the volume controls without pi-topOS”. Does this mean software control of volume, not hardware? Are there other hardware features that are only available from pi-topOS, not on other debian based distros? If so, is there a list somewhere? If so, are there any plans to make these available via an installable package?

Thanks

1 Like