New pi-top 3, no video output

I got my new pi-top 3 yesterday and put it together with my rpi 3 b+. When I started it up, the logo appeared for a second then nothing. I tried 3 other, regular, rpi 3s with the same card. I then downloaded a fresh pi-top os sirius and flashed it to 3 other SD cards, all of them sandisk. I tried 2 16GB drives, a 32GB and a 64GB. None of them output video. At one point I thought all of my raspberry pi’s were bricked, so I downloaded the recovery image and fruitlessly tried to recover all of my pi’s. I then flashed them all with raspian and they all work, except not in the pitop, I assume because some drivers are needed from pitop os. I don’t think there is anything wrong with the pi-top, but there is definitely something wrong with pitop OS. I was trying to find a download to an older version of pitop os, but I couldn’t find it, so now I’m stuck with a really cool paper weight.

Good evening,
You can find Polaris here:
Otherwise the version of Sirius that works for me (I have the same problems):
All the other versions of Sirius do not want to work on my Pi 3 B+ unlike my son’s pi-top3 which in the latest version of Sirius (Pi 3 B)

1 Like

I’ve tried all of the above. Like I said, it came on the first time I booted it up then went to a blank screen. I haven’t been able to make it do anything since that moment. Very frustrating.