OS update not working

hi,

I downloaded the latest OS, and it boots fine.

I ran the Updater, and the machine hangs.
I ran the updater several times, and it hung each time.
I downloaded the OS again, and repeated the steps above, and it hung each time.

Unfortunately for me, I was also doing one of the iterations during the Google outage. So, giving the benefit of the doubt, I tried again. Same result.

There seems to be an update with the apt-get update.

Anyone else having this issue?
Thanks

I haven’t had the exact same issue, but I had a similar issue - It would fault out without telling me why. I was using an 8GB SD card and it didn’t have enough room. After changing it out for a larger SD I haven’t had the problem again. How large is your SD card?

Can you give us more information about when the machine hangs? Is it pretty much immediate? After the choice to view the updates or just install them? Can you view the updates?

Also, you mentioned using that using apt-get update finds updates. Have you tried running sudo apt-get upgrade and if so, does it also hang? For my problem, the error messages in the terminal gave me the information I needed to fix it. Hopefully this helps you too!

hi,

Thank your for the reply.
My SD card is 16Gb. My Pi is 3 Model B.

I have re-imaged the SD card and done the first time boot procedure, then the built in OS update via the OS Desktop.

I will, after this test try to run the commands manually as you have asked.

In the meantime I have included an image of where the hang happens - apparently on some Real-VNC work being done.

I will now reboot the Pi and see if the auto recovery logic does anything to fix the issue.
After which I will re-image the Pi and then run the standard apt-get updates for upgrading Linux Distros.
Thanks

I manually ran:

  1. sudo apt-get update – ran ok
  2. sudo apt-get -f install – ran ok
  3. sudo apt-get upgrade

280+ updates…
hung… then let the computer sit for 30 minutes, in case the screen was just not rendering and was actually working in the back ground.
When the green light on the Pi stopped blinking for a while, I power cycled the Pi.

The machine did not come back. Essentially pooched.

Thanks again for the help, I appreciate it.

So it happens with apt-get at the terminal as well. Interesting. I’ve installed Sirius and run updates about 5 times now on two different Pi-Tops (I have a CEED and a [3]) and I haven’t had this problem. I think the next thing to do is try to rule out a hardware failure. How do you feel about…

  1. Trying a different SD card. I could easily see a faulty SD card causing this problem.
  2. Removing the Pi from the laptop and connecting it to a TV and USB kb/mouse. If the problem goes away, a hardware issue with the laptop itself (maybe the hub) might be the root cause. I can tell from the picture that you have a Pi-Top[1]. Speaking from experience, their hardware reliability record is slightly less than perfect.
  3. Putting a different Raspberry Pi in the laptop if you have access to one. I think this is the least likely, but it’s possible I guess.

If I were a gambling man, my money would be on #1. But I’ve been wrong before :upside_down_face:

Uninstalling VNC might be worth a try, but it also might cause the next thing to fail (or postpone the failure) if it’s a problem with the hardware. I’m also making the dangerous assumption you don’t need VNC.

I can try the new SD card.
I can remove VNC … I do everything remotely via Putty.
Taking the Pi out of the laptop is too drastic at this point, the machine is for people with wee fingers and young eyes. Although I may surrender later and go down this branch.

Thanks.

I used a new SD card, also bigger 32Gb
I ran the upgrade and left VNC installed. Success.

My assumption at this point is my SD card was bad.

Thank you for the help.

Oh good, glad it was a (relatively) easy fix. Hope you can have some fun with it now!