Pi-top [1] blank video issue

I have a pi top 1. The pi itself puts out video on the HDMI port, but I don’t get video on the screen. When I turn the unit on, the screen lightens up just a little, which tells me it’s getting some kind of signal. My guess based on this is the power board pcb might have an issue.

I was wondering where I could get a replacement power board PCB and/or maybe a screen.

Or if anyone has any other suggestions.

Thank you

I would remove the cable and look carefully at the connectors and see no problem. I would then brush them vigorously with an old toothbrush or something like that. I’d brush the connectors on the boards, too. A little DeOxit R5 (perhaps from the mini-spray can on Amazon) on the brush after the cleaning pass. DeOxit is basically harmless to electronics, but don’t pour or spray it on directly. You just need a drop. I say the above because cables rarely go bad, but connectors can oxidize, and DeOxit is a good approach. I would, of course, also try a different cable. It’s worth having some adapters around to allow replacing strange cables. I just ordered two each of the bridge board and the main board for the V2 laptops so that I can finally, really, debug those by swapping things out. I found those on eBay.

Thank you. I don’t see any sign of oxidation, but I’ll look into cleaning them.

I see the bridge boards and other parts for the newer laptops, but not this model anywhere inline.

Are there direct repositories or direct downloads for the drivers for the specialty board and screen?

Cleaning is done, no luck, but it was pretty clean anyway.

Do you get any output using a different screen, like a TV? You can rule out the connectors if this works and the cable.

If you do get an output to a different screen, it could be the resolution of the screen you are connecting to, what pi have you got? The newer OS could be forcing 1920 x 1080 and the screen is a lower resolution, it doesn’t have a way to display what it is being sent.

The config will need manually updated to send the correct resolution through the HDMI.

Had a similar issue with Rasp Pi4 and the pi-topCEED as it’s only a 1366 x 768 screen.

I get output from the Pi to a monitor, so I know the pi works. I have used other cables from the pi to the power PCB.

Do you know for sure what the resolution should be for the Pi-Top [1]? I’m not sure i’ve see that 1366x768 resolution. Maybe it has to be very specifically the “native” resolution, but I tried 720, 640 and 480 as well as 1080. I didn’t try any interlaced resolutions, but is there a way to set 1366x768 (or whatever) if it isn’t listed in the drop down/selectable resolutions?

Hi @davidstoll

I don’t know for sure what the resolution is, but alot of earlier screens, pre HD resolutions would have been able to use 1366 x 768. It won’t damage anything amending the config.txt file and can be easily undone by deleting the amendments and saving the file or copying over a backed up version to overwrite it.

Sorry if these instructions appear a bit condescending, I’m not sure of how much you already know. Also, they may help someone else finding them on this forum.

Just encase something unexpected happens, shouldn’t normally cause an issue, but better to be safe, backup!! or make sure you have a way to reflash the card if you don’t have anything important on it.

Insert the Pi memory card into a card reader on a PC or other computer and open /boot/config.txt in a text editor, like notepad on a PC or the equivalent on your chosen platform. Most will have a default when you double click the config.txt file.

Copy and paste the 4 lines below to the bottom of the config.txt file you have open.

#User Set Screen Resolution
hdmi_cvt=1366 768 60 3 0 0 1

Mine is a Raspberry Pi 4 so I also had to comment out the below line by adding a # in front of it, just look through the config.txt file to find it.

Changed dtoverlay=vc4-kms-v3d
to #dtoverlay=vc4-kms-v3d

Save the changes and safely remove memory card
Put the card back in the Pi and boot it up, the full image should appear on the screen.

The above may need commented out to use full resolution on a different screen in the future, so would look like this

#User Set Screen Resolution
#hdmi_cvt=1366 768 60 3 0 0 1


Change #dtoverlay=vc4-kms-v3d
to dtoverlay=vc4-kms-v3d

Hopefully this works for you also

Hi, thanks, that was helpful. I also am attempting to use a Pi 4, so I followed exactly what you did. The pi-top screen didn’t come up, but it still doesn’t appear to be using the resolution set in the config.txt. I say this because when I plug the pi directly to a monitor, it looks full HD to me. So, I have attached my config.txt and a screen capture of the resolution gui so you/anyone can see what is there.

I don’t see a 1366, but I do see a 1360. I tried setting that in the gui interface, rebooted and, while the pi-top screen didn’t come up, the monitor plugged directly in, did reduce down in resolution. It commented out the hdmi_goup=2 line, but left the other lines alone.

I put the config back, set the resolution to “default” in the gui and rebooted…so that is what is attached/below.

Thank you again!

# Some settings in this file are managed by pi-topOS programs and services. # Details can be found in the OS documentation: # File: /usr/share/pt-docs/os-configtxt # Website: https://pi-top.com/pt-docs/os-configtxt #////////////////////////////////////////////////////////////////////////// # For more options and information on how settings in this file work, see # Raspberry Pi Foundation's documentation: # http://rpf.io/configtxt # # Some settings may impact device functionality. See link above for details # Additional overlays and parameters are documented /boot/overlays/README #////////////////////////////////////////////////////////////////////////// # DO NOT EDIT 'ptconfig' SETTINGS # USED BY THE OS TO SUPPORT BUGFIXES AND LATEST FUNCTIONALITY # # pt_config_txt_orig_version=2020.12.14-1_all # pt_config_txt_mods_applied= #//////////////////////////////////////////////////////////////////////////


Display stack configuration /


Default case: 1 display maximum


Default case: legacy driver

Compatible with all non-Pi 4 models



RPi 4: 2 displays maximum


RPi 4: DRM VC4 V3D driver on top of the dispmanx display stack



Additional networking configuration /


Enable USB-C Virtual Ethernet port

Required by pt-networking (not pt-display-port)



HDMI configuration /


Force HDMI out

- allow hotplugging a display

- allow VNC without a display attached



Prevent black border of unused pixels


Enable sound over HDMI


Allow HDMI display to go into low-power mode when idle


Uncomment if you get no picture on HDMI for a default “safe” mode


Uncomment to increase signal to HDMI, if you have interference, blanking, or

no display



Hardware interface configuration /


I2C - used for communicating with pi-top hubs


UART Serial (locks VPU core freq to 250MHz) - default off

Available on pi-top PMA


Extra video codecs in Raspberry Pi GPU firmware; adds native support for Raspberry Pi Camera - default on



System configuration /


GPU memory allocation - default 128MB


Audio - default on


Rainbow splash screen - default on


#User Set Screen Resolution
hdmi_cvt=1366 768 60 3 0 0 1

I’ve pulled and re-seated all of the cables, but I just can’t get video to display. I can’t tell if it is the screen itself or the little PCB power board. Is there a replacement screen or power board available somewhere? Or a way to narrow it down (assuming there are replacement parts options)?