Pi-TOP [1] hub mk 1 not communicating with Rasp 4B

Hi!

I was gifted the pi-TOP [1] a few years back, and I recently upgraded the raspberry pi in it from the 3B model to the 4B model. After some screen troubles (which were solved by my software engineer dad), we were able to get the new raspberry pi to use the screen and keyboard of the pi-TOP [1].

The current os that we are using to make the set-up function is:


Raspberry Pi OS with desktop and recommended software
  • Release date: April 4th 2022
  • System: 32-bit
  • Kernel version: 5.15
  • Debian version: 11 (bullseye)

We tried to use pi-TOP OS Bullseye, which resulted in the raspberry pi 4B shutting down suddenly after trying to boot up.

After some testing with raspberry pi os we are currently using (see above), we found that the hub wasn’t properly communicating with the raspberry pi itself. For example, the pi-topSPEAKER isn’t working, and the raspberry pi isn’t turning off when I shut it down.

Any help would be greatly appreciated!