Pi-top [1] No Display - bullseye

Hello,

I have a pi-top[1]. Recently starting it back up after a couple of years on the shelf.
I have in the last day or so, installed several OS.

  1. Jessie circa 2016 - worked fine, just can’t upgrade it as apt-get stuff is 404
  2. Stretch circa ??? - worked fin, same… apt-get issues
  3. pi-top OS - sirius - depricated, but screen works fine.
  4. p-top OS - bullseye - screen not showing - iterated on values in config.txt no avail.
  5. Raspios - bullseye - screen not showing … came here

Ok, so the screen is fine … since the older OS show content on screen with no issues.
I feel like the refresh rate or HDMI is having issues.
Has any one else in the community been here… done that… fixed that…?
Google has not yielded a solution yet…
thanks in advance

I installed the Raspberry Pi SD card imager.
I used it to flash the SD card with a 32 bit image.
The Pi-top booted, resized the SD card image.
The Pi-top rebooted… to a blank screen… I was hoping this was a 32 vs 64 bit issue, but no such luck so far.
The SD card is 32Gb.

I removed quiet splash from cmdline.txt
I can now see boot messages. Everything whizzes by quite fast, then dumps into the blank screen.
I attached a screen grab of a video I took of the boot.
I’ll continue iterating on options.

interesting… I put the SD card into another Pi, with a 5" touch screen, and the desktop came up, without issue.

item to note, the screen briefly mentioned that there was no signal, then continued on, as if it were searching for a valid means to output.

To me this seems like an OS level issue. Just as if the Pi-top team had not been in communications with the OS dev team and shared the information about the Pi-top[1] screen so it was not included in the default list of supported hardware.

To me, it seems like an expert at Pi-top[1] should be able to iterate on the settings for config.txt or cmdline.txt and share which settings get the OS to cooperate. I have not yet found success, but my test shows the issue is not with the SD card nor the OS on the card. Seems to be the configuration of the OS and how it finds the hardware and adjusts.
hoping someone much better than I has resolved this already…

Hi Ackman
I’ve seen this a few times and it’s usually to do with the 1st generation pi-top [1]s. Those screens were 1366x768 and not 1080. Unfortunately, it’s because we set the screen output to 1080 by default. For some reason, the very first production units of the pi-top [1] won’t allow any image to be displayed unless the input is 1080. But you’re right, the best way around this is to change the config file to automatically output the native resolution

Unfortunately, we stopped supporting the pi-top [1] at the beginning of this year since it’s now 7 years old.

I hope I clarified things, have a great day!
-Rez

Hi Rez,
Thank you so much for responding to my question about super obsolete hardware. I really appreciate it.

I have tried…

I tried several of the options for my Pi-Top[1].

I tried mode=16 [1080p]that didn’t go well, even the text display at the start of boot up was mangled.
I tried mode = 5 [1080i] that was better, at least the text at the start of boot is on the screen now.
I tried…
hdmi_force_hotplug=1
hdmi_ignore_edid=0xa5000080
hdmi_group=2
hdmi_mode=87
hdmi_cvt=1360 768 60

Same behavior text at initial boot then nothing

I tried the whole file commented out. failed - text at start then blank

I tried:
hdmi_group=1
hdmi_mode=5
hdmi_cvt=1080 768 60
Reboot - Fail - interlacing issues

I tried:
hdmi_group=1
hdmi_mode=16
hdmi_cvt=1080 768 60
Reboot - Fail - boot text ok -

I tried to run sudo raspi-config - which doesnt’ work well when run from cmdline.txt at init=/bin/sh, seems to not want to save the file on SD.

I don’t know what I need to put in the config.txt file to make the pi use native default resolution. I tried the commented out all values on that iteration.
Thank you in advance

Sorry Ackman,
The best thing I’ve seen is to use Raspberry Pi OS. That OS queries the resolution of the screen and then outputs accordingly, otherwise it defaults to a much lower resolution that can be adjusted. However, when pi-top OS can’t see a screen it assumes that the user will use VNC to connect and then outputs 1080p

You can also try downloading Raspberry Pi OS and then installing the pi-top packages ontop. We have a guide showing what to do here.

Let me know if that helps.

Kind regards

I am using the Rasberry pi imager software… with…
Trying to use 2022-04-04-raspios-bullseye-arm64.img 32bit …
I will blast the SD again and run through options again. using VNC seems like the most reasonable option at this point.

I also customized the config

  1. join wifi
  2. allow ssh
  3. set host name to be “special” and easily identifiable

I will SSH into the pi and raspi-config to enable VNC and then go from there.

I will keep you posted. Thanks again.

I was able to VNC into the pi-top raspberry pi.
The bullseye desktop does not see an HDMI device. Which explains it not outputting to the pi-top built in screen.
I am patching the OS to bring it up to current. I am hoping a patch in one of the modules fixes the issue.
I will keep you posted.

Hello.
On my Pi-top[1] I was able to boot up and get the desktop to appear.

  • Raspberry Pi OS Bullseye edition
  • pi-top[1]
  • raspberry pi 3B
  • wifi working
  • wired LAN working

the magic or the last domino to fall was commenting out a value in the config.txt file.

#Enable DRM VC4 V3D driver
#dtoverlay=vc4-kms-v3d

The line above included for reference.
I believe I’ve read that the vc4-kms-v3d is related to Pi 4 and Pi 400, so it stands to reason that can be removed for Pi 3 generation of Pi.

Cheers.

1 Like

Hi @ackman
Thanks for this, was the last piece of my puzzle with the pi-topCEED.

Our Scout group got 6 Rasp Pi 4 b’s and pi-topCeeds 2 years ago but with Covid they got put in storage. Been banging my head trying to get these working. I had output when using them with Raspberry Oi OS, but it was getting skewed at 45 degrees and unusable. No issue with VNC and attempted several HDMI configurations with no change.

Instantly resolved with commenting out the dtoverlay=vc4-kms-v3d, to confirm this is a Raspberry Pi 4 and it’s 100% working if anyone else has issues.

Thanks again, first place I saw this as an option to change on any forum