Pi-Top 4 DIY cannot open case. Screw stuck

Got an early-bird Pi-Top 4 DIY and a separate Raspberry Pi 4B 8GB.
Today I wanted to install the RPi 4 in the Pi-Top 4 DIY.
Started with trying to remove the 2 screws of the bottom plate as in the assembly video.
First screw no problem. Second screw, no luck. Now the scre head is damaged and I am stuck.
Should I return the DIY and get a replacement? Or any suggestions how to open the case?

Problem solved. Got a screw-extractor kit and managed to get the screw out.
After this, installing the RPI 4B as in the tutorial video went smoothly.
Replaced the destroyed screw with one of the spare ones.
Now it is working fine.

@tvoverbeek good to know that you solved the problem. Would you mind sending a photo of the screwdriver that you received? I want to make sure that the head type was correct (should be a cross-head)

Here is a link to the screw-extractor kit i used:


These are drill bits for an electric hand drill.
Of course the original screw gets destroyed.
The head was already damaged by my attempts to get it out before I got the screw-extractor set.
Luckily there are a few spare screws with the DIY kit.