Pi-top [4] not turning on

@bob just to confirm, is the USB-C power cable plugged into the port on the left with the lightning bolt? i.e. not the port with the green surrounding.

If that’s the case then I would recommend emailing support@pi-top.com and getting a replacement sent out - if the unit is showing no signs of power or activity then there may be a problem that we are unable to debug remotely :pensive:

yeah it’s connected to the bolt one
oh fudge well I just got it today
fudge sake…
thank you for your help though I text them immediately from today and ship the package props tomorrow…
Thank you once more

@bob hopefully you get the replacement soon, let me know once you’re up and running!

I got the replacement today and is running like brand new just doing few things to it now as in installing the OS for the screen for the pi top as I’m running rasbian


Hi guys,

We have fully charge our pitop4 with the proper 15V and the screen indicated 100% charge.
However, nothing happens while we try to turn it on
What are we supposed to do then ?

Ok, I have a bug report which may be related to all of this, “pitop wont turn on.”

If you leave the display connector plugged in and it doesnt turn off correctly, ie have to hold the power switch, it seems that the mini-hdmi connector is feeding power to the raspberry pi and preventing a full power cycle. Will be reporting in new thread.

@Stef do you have an SD card plugged in?

Hi duwudi, yes we put one with pitop os system

@Stef if you hold the power switch for 2-3 seconds the green light should come on - does this happen?

I have just tried again and no light at all in the bottom
there is a green light inside

@Stef did you build a DIY Edition? If so it may be because the pi-top can’t detect the Raspberry Pi. Could you send me a video of you trying to turn it on and show me what happens? Just post to YouTube as unlisted then post the link here, try to show the RPi LEDs etc when you try to turn it on too. If we can’t figure it out I’m happy to jump on a Zoom call to help you through it!

ok I keep you posted while done

Hi Duwudi,

Sorry for the delay below the link to our video

Have you tried disassembling the pi-top and verifying the pi still works as intended? I’d say start with that, and if it does, try reassembling it and take some extra time to make sure all the connectors are the right way around and seated properly.

Other than that, I think @duwudi would recommend contacting support at that point. :confused:

@Stef apologies for the late reply, I was moving apartment over the weekend so was a little busy! Can you plug the PSU in and do the same thing? You mentioned you had 100% battery showing on the display when you did that which means the system does seem to be active. We can also try resetting the internal MCU, there is a small hole on the bottom of the pi-top [4] near the gold pogo pad connectors - get a pin and press the switch inside there and see if the that fixes it :+1:

As I mentioned, if you built a DIY Edition and the Raspberry Pi can’t be detected then it might be a bad connection at the silver connector on the mezzanine - we refer to this in Step 10 here

Hi Duwudi, Supernovali,

Just to inform you that issue was solved just by ensure that the silver connector was properly set up on the mezzanine.

At the end, the elephants laboured and brought out a mouse,

thank you so much for your support ++


You’re welcome! I’m so glad you were able to get it up and going! I’m loving my pi-top. Really, my troubleshooting was just from years of experience with hardware. The real person to thank is @duwudi

Also! If someone isn’t active on the forum, unless they are “watching” your post, they won’t get notified unless you tag them with an “@” symbol. :wink: What is cool about this forum is that at the bottom of all the threads right above the “Suggested Topics,” you can select your level of notification for a particular thread. I think if you respond to someone, by default it gets set to tracking.

@duwudi, I can’t remember who we talk to about forum suggestions… Can we get it to default to Watching if we send a reply to a topic? And if we click on a topic and love something, can we get it to default to Tracking? Or let the user assign automation to that? That would be super neat!

@Supernovali yeah that’s a good idea as notifications are so important, took me a while to get mine right!

@RezIN is the one to talk to about that, he’s the super admin :smiley:


@Stef good to know, happy making! :+1:

All works well for me now! I had the same problem and worries. I didn’t know that USB PD is different than regular USB C. I learned something today :slight_smile: