Pi-top [4] not turning on

Hi!
I’ve just received my pi-top DIY 4 kit and successfully connected everything but after turning the power switch on, nothing happens… So far I have not succeeded to making it boot with pi-top connected:
Usb-C cable from my power adapter is connected to pi-top usb-c power connector and nothing happens after turning the power switch on.
I tried troubleshooting it, so I disconnected my RPI from pi-top and connected it to my hdmi monitor and power adapter DIRECTLY and pi-top OS booted up nicely.

That tells me that there is something wrong with pi-top itself.
Also, there was no pi-top display cable in the pi-top DIY box - is this normal?

Can you help me fix this?

The same here.

The RPI 4 connects and runs when outside the Pi-Top case but when inserted in the Pi-Top 4 case nothing happens, no red and green PI lights, no screen, nothing.

Updated EEPROM but changes nothing.

HELP - NOT Working - FIX Required

1 Like

Yes, I also thought that updating EEPROM (as per knowledge base) would help but sadly it didn’t do anything.

Is there any way to check the pi-top itself if it’s broken or something? I’m currently waiting for customer support email reply to find out if I was sent a damaged pi-top unit maybe :confused:

Should there be any indication of charging when connected to power even without rpi inside the pi-top? To see if the pi-top is at least charging itself.

Hi urosss does the little display show anything?
you need to hold the power button on for a few seconds.
Dale.

Hi @urosss,

Is your USB-C power supply capable of supplying 15V? It must be USB-C PD specification, pi-top [4]'s official PSU is 36 watt but you can get away with 30 watts for most applications

pi-top Display Cable is sold separately

@Dale, good point - the OLED Display and the LED behind the power switch should indicate that the power is connected if the power supply is within specification. The pi-top [4] ships in sleep mode so a power supply within spec is needed to wake it up

@pmviana see my message to @urosss, please check the specs of your power supply - 15V is needed and ideally at least 30 watt

I tried charging it with my 61W macbook pro charger.
It’s labeled as 20V, 9V, 5V USB-PD.
There is absolutely no led indication of any charging / power whatsoever.
Do you think the charger is the cause, should I order an official one?
I could do that but I’m afraid once the charger gets here, that won’t help…
Is there any other way of checking that the pi-top is ok?

There is no led or display indication of any charging / power after holding the power button, no.

I’ve missed that vital part of the Information.

Mine seems to be charging now that I’ve connected it to my Mac charger power supply.

Do you have any recommendation for the power supply?

Best regards

@urosss It seems your MacBook charger doesn’t support 15V which is what is required. Apple not conforming to the USB-C specification, what a surprise… :wink:

As I said, the internal battery is in complete shutdown mode for shipping - the only way to wake it up is by supplying it with 15V so there is no way to check things are fine other than that. It’s highly unlikely your [4] has an issue - get the official pi-top PSU or one on Amazon - you can search “USB-C PD Power Supply 15V”

1 Like

@pmviana Either the official one at pi-top.com or literally anything else that supports 15V with minimum 2A (2.6A recommended if you’ll be using the pi-top Touch Display and/or future pi-top robotics kits [MMK])

I’ve placed an order for original pi-top charger and will let you know how it went when it gets here :wink:
Thank you again for your help!

1 Like

I confirm this situation. See the following photo

1 Like

I’ve received the pi-top charger this morning and I can confirm that this time the pi-top has “come to life” :wink:

Thanks again for all your advice, have a nice day!

Excellent, happy making! :grin: