Pi-Top [4] Spares - Batteries

Is there a topic to discuss / order Pi-Top [4] Spares? My Pi-Top has been on, more or less constantly for 2 years and the battery is “dying” - now only charges to 34%. … should I replace it, if so with what and how to order?


Hi @nannerbm60,
We don’t currently offer spare battery parts but we can talk about it. Since you’re abroad, we’ll have to discuss a way to ship it out to you. I’ll contact you by email and we can talk about it further


@nannerbm60 has it been on and plugged in for 2 years or do you frequently charge and discharge it?

@duwudi - It has indeed been “plugged in” for roughly the whole time. … It might be a bit shorter than that … It was in use from the month that the displays and keyboards reached Australia

It did raise a question in my mind of when it was first “built” … I hunted and could not easily find a first date because I have had it booting from an USB SSD since whatever version of the OS allowed that - and the last time it was “off” for any length of time was when I replaced the fan … I probably should have thought the battery life issue through …

Any way to recover it? Or should I just let it bleed out?


@nannerbm60 In general it’s good to cycle the battery every now and then as it’s used for recalibration of the capacity readings - you could try letting it run down and then charging it again to see if it makes any difference

Judging by the thread here it looks as if the battery cannot be replaced, which is an annoyance.

I can’t find any support material to resolve this. The device did not get past 20% or so recently and now will not start. I’ve removed the Pi 4 front the Top and that works fine, it’s just the base unit which is causing the issues.

Any advice gratefully appreciated.


Hi -

I can’t quite understand what you have tried from your question … you wrote “removed the Pi 4 front the Top and that works fine” … “front” - … do you mean “from” … what do you consider to be the “base unit” to be?

My Pi-Top runs with the battery permanently at 0% … It is an issue when the power goes off - which is a pest. … The USB - Power cord is loose, but that is just a matter of not moving it! That works for my application (as a UniFi controller) … but maybe not for everyone

In order to use a Pi 4B in the Pi-Top a cover has to be removed from the Pi-Top leaving the remainder of the unit, which I referred to as the base unit. That is accessible and was part of the remit for adding a Pi to the DIY Pi-Top. The Pi4B works perfectly fine isolated from the PiTop.

All I want to do is replace the battery that appears fault but there does not appear to a feasible solution to access the existing battery. If this is not user replaceable then I will chalk this up as a lesson learned and seek alternative solutions to running a battery based Pi.

I can’t quite understand what you have tried from your question … you wrote “removed the Pi 4 front the Top and that works fine” … “front” - … do you mean “from” … what do you consider to be the “base unit” to be?

I, too, have a Pi-Top [4] w/dead (really most sincerely dead) battery. It will only power up when the base plate (robot) is detached. 0% charge, but indicates charging. Is it true the battery is not user-replaceable? If it is, where can I buy one. If not, can I have it replaced if I send it in?


Unfortunately the manufacturer isn’t too forthcoming with a resolution. They asked if my device was under warranty, it isn’t. That’s the last I heard from them!

I too would appreciate some feedback on how to replace the battery or fix the battery firmware issue.

My pi-top[4] only ever shows Charging 0% in pi-topOS and on the OLED screen despite using the official pi-top charger.
When I run pi-top battery I get:
Charging State: 1
Capacity: 0
Time Remaining: 0
Wattage: 0

Rather than a completely depleated and dead battery, the above to me would suggest there is a firmware problem with the battery management.

The generic firmware update software seems to have done its job and I am running v5.4
Running pi-top devices returns HUB pi-top [4] (v5.4)
I also tried it running manually sudo pt-firmware-updater pt4_hub but there doesn’t seem to be any newer versions.

Any help or advice would be appreciated.
Many thanks

I found some info from users with similar problem who have fixed this using pt-battery-fw-update but it seems to be quite out of date. After getting it working by installing the WiringPi from an alternative repo, I get Error No: 121 in a loop instead or the expected Error No: 5 or no error at all.
A v2 seems to exist but I could not find it.

I have exactly the same problem. I turned my pi-top after few weeks being not used, and it seems that battery has died.

HUB pi-top [4] (v5.4)

pi-top battery
Charging State: 1
Capacity: 0
Time Remaining: 0
Wattage: 0

I tried to connect to different power adapters, using different cables and device still shows that battery is charging but still 0% and no progress.

pt-battery-fw-update also shows “Error No: 121”

1 Like

That firmware updater you are referring to, it would update one of the chips on the battery ?
I’m inclined in trying to replace the 18650 batteries with new ones and re-solder the connector and board in place.If it’s the same 7.4v, I can’t see what would be wrong.
I see they use LG M26 cells, Anything would be better. But before I attempt this surgery, I would like an idea if this is the issue or not. The batteries did not last a year in my case, they were manufactured at the end of 2020, I mean… they probably have 10 cycles on them!

That’s cool idea - I can’t break it more. For me without properly working it is useless.

The question is: how to reach battery pack? I tried to remove cover with oled screen but no success.
There are two screws under black sticker at the bottom… but no luck after unscrewing them. Are there also other ones below green feet?

1 Like


There is no update.


2 bottom screws behind rubber feet, and 2 black screws on the side, you need to remove the cover on top of the pie to see them.

Yep… Done. I reached the battery pack and disconnected it. Ordered spare “LG INR18650 M26” batteries - exactly the same as included in original package. Waiting for delivery.

The only doubts I have are connected with all those “security measures when working with such batteries”. I understand: “not short-circuit it”, “watch polarity”, but what about soldering? How to attach contacts back?


I would not have replaced them with the same model, they are notorious. If you ever want to try something else I would say stick to standard cells, 3.7v, and good brands like Samsung, Panasonic or Sony.

As for soldering, those are spot welded, very common for mass production of those cells. You can buy the same nickel strips, they are cheap. Tin and lead solder sticks well to nickel, use flux and it will be easy to recreate the same pack. Complete with shrink wrap! :wink:

Thanks for tips.
It’s done, but… it would be to easy if it was working :slight_smile:

I booted up with power adapter and it was showing 22%. It was also showing charging.
I left it connected overnight and now it dropped to 19% and still charging.

I cannot boot up on battery and after disconnecting power adapter it turns off.
Do I have to reset it somehow? Or something else broke in battery pack?

Screenshot 2023-02-12 at 14.54.13