Pi-Top Hardware on Raspberry OS {PI TOP 3}

Hello I have bought a pitop 3.0 laptop.

I use it for work and I need to run clean raspbian, I would like to be able to at least tell the battery level.

I have tried following this page:

However when calling the last command I get a bunch of errors; Is this code still maintained?

   pi@raspberrypi:~ $ sudo apt install --no-install-recommends -y pt-device-manager pt-sys-oled pt-firmware-updater
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python3-pitop : Depends: python3-dlib (< 19.23.0) but it is not going to be installed
                 Depends: python3-dlib (>= 19.22.0) but it is not going to be installed
                 Depends: python3-flask (< 1.1) but 1.1.2-2 is to be installed
                 Depends: python3-gevent (< 1.4) but 20.9.0-2 is to be installed
                 Depends: python3-imutils (< 0.6.0) but it is not going to be installed
                 Depends: python3-imutils (>= 0.5.4) but it is not going to be installed
                 Depends: python3-matplotlib (< 3.1) but 3.3.4-1 is to be installed
                 Depends: python3-opencv (< 3.3) but 4.5.1+dfsg-5 is to be installed
                 Depends: python3-scipy (< 1.2) but 1.6.0-2 is to be installed
                 Depends: python3-zmq (< 17.2.0) but 20.0.0-1 is to be installed
 python3-pycrc : Depends: python3.7 but it is not installable
 python3-pyftdi : Depends: python3-pyserial (>= 3.0) but it is not going to be installed
                  Depends: python3-pyusb (>= 1.0.0) but it is not going to be installed
                  Depends: python3.7 but it is not installable
 python3-smbus2 : Depends: python3.7 but it is not installable
E: Unable to correct problems, you have held broken packages.

This solved the issues for me:

sudo apt install pi-top-os-apt-source -y
sudo apt update
sudo apt install --no-install-recommends pi-topd pt-miniscreen pt-firmware-updater

I would recommend maybe updating the main website with this info?

1 Like