PI-top not turning on

I bought an pi-top couple years ago to my nephew. Then he grew up and stopped using it for the last year. Now my other nephew is starting to get into computers, when he tried to turn on the computer and plug the power source the pi-top 3 has the power button with the light on but nothing else happens.

Do you know what can possible be?

Hi @gil can you see the backlight of the display come on? Also can you see any lights on the Raspberry Pi? Sounds like either the Rasberry Pi is damaged or the hub isn’t supplying power to the Raspberry Pi. I would double check all the cables are correct. Especially that 40pin connector, it may be that it’s offset my one row or column of pins

The display doesn’t turn on! All raspberry pi lights are off. I tried to connect the Raspberry Pi directly to a power adapter, and it works without problem. The battery conector was a bit loose and I tightened it. I also noticed that the pi-top power adapter is blinking. Looks like there is some problem in the hub.

@gil did you say there’s a blinking light on the pi-top charger? It sounds like the pi-tophub isn’t connected to the Raspberry Pi. Is the micro-USB cable connected from the hub to the Raspberry Pi and is the 40pin cable connected correctly from the hub to the RPi? Remember that the wires should be fed away from the Raspberry Pi (if there’s a red cable, then it should be on the SD Card side).

If you’re getting power to the hub, then there’s an issue with getting power to the Raspberry Pi

When I plug the charger this are the lights on

After I press the button the charger starts blinking but apart from that nothing happens

These are the connections:

I think, as you said, the problem is getting the power to Raspberry Pi