Pi-Top OS doesn't allow program to go pass the first network setup page


New user and Pi-Top tinkerer here.

I have an issue with Pi-Top Os.

When I install and try to run Little Backup Box in the Pi-Top 4 DIY (RPI 4 8Gb) I can’t get past the first network setup of the program.

On first run, little backup box asks for direct wifi connection to the pi (in this case in the pi-top box) and once connected you have to sign in to assign the external wifi. While this is happening the connection icon usually shows as if you were connected by ethernet.

Then you select your wifi network, type the password and the box can be accessed remotely from other machines on the network.

The problem is that when you connect to the pi running pi-top OS the sign in page is always the first Pi-Top landing page as if you were just finishing the set up through VNC. In the rare ocassion it actually lets you get to the Little Backup Box setting page, tthen youdisa select the network but can’t put the password as the webpage gives an error (I think it was a 503 error).

Is there any way to disable that network setting? It is as if Pi-Top Os works behind a proxy or something that is not direct connection to external networks.

If I install Raspberry Pi OS with all the Pi-Top drivers it works as intended, but I would like to stay on Pi-Top OS because I feel the hardware works better under that OS.

For example, when on Raspberry Pi OS I can get the fan to turn on and off by assigning the GPIO port and the temperature on Raspberry options. But then the fan settings are just turn on at full speed or turn off. Not variable speeds as it is in Pi-top OS which would be better as the temperature fluctuates less.

The program I am trying to get working is:



Hi Will,

It sounds like the issue may be that when your browser connects to the pi-top’s IP address it gets a mix of responses from the Little Backup Box server and the pi-top OS ‘Web Portal’ server.

The Web Portal uses http port 80, whilst LBB uses http 8000 or 81 and https 443 or 8443, so there should not be a direct clash but issues may still occur if care is not taken to specify the port that should be used.

One thing you could try for a simple solution is to specify the port in the url you enter to access LBB, eg http://IP.OF.YOUR.BOX:8000 or https://IP.OF.YOUR.BOX:8443.

If this doesn’t work you could disable the pi-top Web Portal. It sounds like you are on our previous OS version ‘Buster’/‘Sirius’, so you would do this with these two commands:
sudo systemctl stop pt-web-portal
sudo systemctl disable pt-web-portal

I would recommend that you migrate to our new OS based on Raspberry Pi OS ‘Bullseye’. On the new OS, the web portal service has been renamed, so the commands must be adjusted:
sudo systemctl stop pt-os-web-portal
sudo systemctl disable pt-os-web-portal

Hello Angus.

Thank you very much for your reply.

I am not sure why I would be in the previous version as I installed the OS from the image in the Pi-Top webpage and went through the updating process.

I will have another look tonight or tomorrow.

I think I will just make a note of the port so I don’t have to disable the web portal.

Thank you once more. This journey into linux and raspberry is very very interesting.

Kind regards.


Hello Angus.

I checked my box for the version. This is what I get:

cat /etc/os-release

PRETTY_NAME=“Raspbian GNU/Linux 11 (bullseye)”

NAME=“Raspbian GNU/Linux”


VERSION=“11 (bullseye)”







In the graphic interface of Pi-Top I get:

So I think I am on the latest version of the software. Is that right?

Yes, that shows you are on the latest OS, Bullseye. So no problem there, I just guessed incorrectly.

1 Like