Pi-topCEED using Sirius does not start

Edit 04 Feb 2021

In the end I flashed a 16 GB Toshiba MicrSD HC I using etcher, my faith that all will be good, and about 40 hrs of time (Flash Rate 0.1 MB/s as stated by etcher)
This time etcher showed success and the PI powered up and I could proceed with the setup

Being bold, I again flashed the 64GB Sandisc microSD UHS-I with etcher
Again etcher showed me 0.1 MB/s and so I let things happen.
After about 40 hrs etcher again showed success and YES, the ÜPi powered up and things turn out to work good also with a 64GB card which etcher in a previous attempt could not manage to flash.

So the story is:
Using etcher to flash micro SD cards with the PI OS Sirius works on my system
A laptop with SD card port and Linux MInt 20
But it is utter slowly

The unpacked OS is 7.8 GB, the packed/ZIPed file is ~2.2 GB
Use at least a 16GB micro SD card

I dd’d “2021-01-11-raspios-buster-armhf-full.img” on the sd card.
This time the system spun up but stopped because it is missing “pi-top os zip”
How did the raspi os know that?

Now I try to flash Sirius on a different sd card (only 16GB), this time with etcher.
Etcher tells me a transfer rate of astonishingly 0.10 MBit/sec.
I don’t understand why.
But this was that way all the time, with every attempt

All right , lets give this a try:
By some reason I lost the micro SD of my CEED.
The CEED is as it was sold thence with a RASPI 3B+
Now I want to use it with the new software version Sirius
(I was not aware of the Pi-Top [1] to [4] until now)
I have brand new 64GB SD cards available and flashed Sirius as of Dec 2020 C781
I noted that using etcher takes a long time, that unpacking the zip file behaves mysteriously slowly. But in the end i was able to flash the sd using dd.
(actually etcher worked out as well, but it told me it would take 2200 minutes to flash.)
I use a laptop running linux mint 20 and the laptop has an sd card port available

The CEED starts with the rainbow screen and then the heart beat stops (The green led)
The screen stays black afterwards
I tried the earlier version of Sirius, C741, having the same issue

I have read that some people are using Sirius with the CEED and not found anyone having the same issue.

Any hints?


Hello Pi-Top Users, I have a problem also with a brand new 16Gb Sd card and the latest version of Sirius, C781, 2020.12.20. I follow the download instructions using Etcher, I then load it into a Working Raspberry Pi 3B+ and What I get is exactly the same problem that I have been having since November 2020. The Pi top Ceed starts to boot up, a purple vertical Line runs from the top of the screen and about 3 cm in from the left edge of the monitor. The os opens but continuously flashes on and off. in between flashes I was just able to get a complete boot up to the main page. I was able, in between flashes to get to the update reminder, top right of the screen. No update needed. In between dark screen and viewable screen, I managed a few reboots but all I have to show for my afternoon’s work is just more wasted time. The last time this happened I bought a ready flashed card from the Pi-Top store. Do I need to do that again? Any solutions from Pi Top Please? William McCarthy New User.

Hi William,
It does sound like a dying display, and I only say that cos I’m getting the same thing on my AOC monitor right now. I’m sure that

Some OSs might work better because of HDMI config settings under the hood, could you try Raspberry Pi OS and see if that makes a difference? If so, then you may be able to copy over some of the HDMI settings onto pi-top OS. Or you could just download the pi-top Packages for Raspberry Pi OS from here.

Let me know how it goes!

@William it sounds like it could be a loose connection - can you check if the internal cable going to the LCD panel is connected properly? Try wiggling it to see if the behaviour changes too. You can also open the two halves of the CEED’s plastic to check that the cable is plugged into the LCD panel correctly. If none of that fixes it we can try to send you a new LCD cable to see if that helps