pi-topOS Bullseye - no audio

Hello friends,
I discovered pi-topOS today and installed it on my Pi4B-8GB and it’s awesome!
But one thing is bothering me - no audio is coming out when I play youtube videos.
Initially I was getting “no audio device present” when I pointed and right-clicked on the speaker icon.
Uncle Google gave me some clues and so I added two lines to my /boot/config.txt which then changed the scenario because now when I right-click, I see the option to select either AV Jack or HDMI, but still no sound is coming out. Volume is at 100.
My /boot/config.txt now has the following lines (I added the last 4):


What should I do so that I can play music/audio from the OS?

Thanks in advance.

@odhiambo First, welcome to the forum.

I have my pi-top[4] devices (currently 2) and have updated to the newest OS built on BullsEye and audio is working just fine, so I don’t think it’s a fault of the OS itself.

In review of my pi-top[4] /boot/config.txt, it doesn’t require any parameters than what is default.

Maybe try providing more information about the set up.

Since this is in the “general” category, let the forum know:

  1. Is your Raspberry Pi in a pi-top[4] or other?
  2. Assuming, if it is, that it is a DIY pi-top[4] since you are using an 8GB Pi, correct?

This is a fantastic forum to get ideas and assistance. Glad you’re here. Provide more details and I am sure someone will have some additional ideas to help you get that solved.

@Tom-B, thank you very much for the warm welcome.
To clarify, my setup isn’t in a pi-top (as yet, but soon!), but just on a barebones Pi4B. It’s just the pi-topOS installed.
The OS is fully updated.

@odhiambo - Oh Ok… I haven’t ever tried that myself. But since you have me curious, I will give that a try and see what happens.

My initial thoughts are that the pitopOS audio drivers are specifically for the pi-top hardware. But I could be wrong, so I will give it a try.

@Tom-B I am sure the last two lines enabled me to access the sound device. Before I added them the device wasn’t there.
On the sound coming out after that, I am happy to say there is sound. It was a red herring caused by my speaker. I had attached an Amazon Echo and it kinda needed a reset of the audio configuration (line-in). Once I did that I was able to get sound.

@odhiambo - OK… because I installed a fresh copy of the pitopOS and fired up a Raspberry Pi 4 8GB and without any changes to the default setting, I have audio without issue. I did not have to change the /boot/config.txt file at all.

Just so I understand, prior to making changes to the /boot/config.txt that you made:

  1. You didn’t try just a headphones or speakers connected to the audio output?
  2. You were trying a connection to an Amazon Echo prior to just trying a “typical” audio connection?
  1. No I didn’t try just headphones. The only speakers I have are the Echo 4th Gen and Echo Studios.
  2. I have a cable connecting the Pi to the Echo.

I think I will remove the lines I added to /boot/config.txt, reboot and then see.

It does seem like it is a set up with how you’re trying to reproduce audio from the Pi rather than it being an OS issue. An audio connection directly to the audio output (speakers or headphones) works without issue. Have fun troubleshooting.