pi-topOS-sirius_C737_2020-04-23 kill my pi-top3

Hello. Happy owner of a pi-top3, since yesterday, I’m distraught.
My original SD card being out of service, I changed it and therefore download Pi-Top OS again.
Surprise new version: pi-topOS-sirius_C737_2020-04-23
First boot and first steps OK and then restart the PiTop Os logo then black screen.
However with Raspbian no problems.
Really a shame not being able to use Pi-Top OS.
A solution ?
SD card : Sandisk Class 10 256 Go on Raspberry Pi 3B+ with pi-topPULSE

Hi @bu3304. Thanks for getting in touch, though 256 GB cards aren’t officially supported with Raspberry Pis. The maximum officially supported size is 64GB. I can’t find from the internet if this is a hardware or software limitation, so I can’t confirm if this is the root of your problem. Can you try using a 64GB or smaller card to see if this works?

Good evening.
Thank you for the answer. Bad news : ok on 64 GB Sandisk Class 10 but after pi-top update and reboot , black screen returns. no smaller capacity card. I am surprised because pi-top C712 worked perfectly on my ‘old’ sd 128g card. Unfortunately, I no longer have pi-topOS-sirius_C712_2019-11-25 img. It would be a shame to stay on Raspbian.

Another attempt with finally an 32 GB Noobs sd card.
Same problems :

  • first boot ok
  • setup ok
  • reboot at finish ok
  • restart ok
  • pi-top os update ok
  • reboot and return of black screen of Death after the Pi Top logo at startup.
    I even downloaded the img file pi-topOS-sirius_C737_2020-04-23
    Really upset, between the lost of pi-topDASHBOARD, pi-topCODER when switching from Polaris to Sirius … now lost of pit-top OS from sirius to sirius update.
    And impossible to find pi-topOS-sirius_C712_2019-11-25 (which worked well on my 128 GB)

Hello, here’s some news:
I thought I’d solve my problems with the new version:
Unfortunately always black screen after pi-top updates (use of a Sandisk Class 10 64 go card)
Really too bad.

I just tested with a fresh installation on mSD 16go of pi-topOS-sirius_C741_2020-05-18 and always the same problem : reboot random on black screen.
I managed to find the version pi-topOS-sirius_C712_2019-11-25 that works perfectly on mSD 64 GB.

Same mSD with Sirius C741 on the pi-top3’s children works like a charm !!!
His configuration: pi-top3 with Raspberry Pi3B
My configuration: pi-top3 with Raspberry Pi3B+ and pi-topPULSE
Can it be an idea?

@bu3304 could you try without the Pulse? Please remember that you shouldnt hot plug the pi-top Pulse into any pi-top. If it still doesn’t work I’d like to try replacing the hub in your unit.

Good evening @RezIN
No, unfortunately it does not work even with the pulse disconnected and a fresh installation of Sirius C741 : black screen when installing updates after the first reboot.
Only the C712 version works perfectly on my pi-top3. While my son turns him on the C741 perfectly.

@bu3304 can you see any of the lights on the Raspberry Pi when the screen goes black after reboots? Do the green and red lights on the hub work completely fine? Lastly can you see the backlight of the screen as well?

If you need a download link for C712 while our OS team fixes the problem then I can arrange that for you.

Hello @RezIN,
Thank you for worrying about the problem. Leds blink well as if activity but black screen.
I dropped pi-topOS for me, because now use like a chromebook so Raspberry OS is perfect for my current use. It’s just a pity not to be able to stay on the original operating system especially that for my son it works normally and perfectly with C741.

I also found a good link to download the c712:
No problems with this same version on a 128GB card but the latest version of Raspbain works like a charm too and i preffer to stay on it:

Glad to hear that it’s working!
I’ve logged the bug wtih the OS team, hopefully we can find a fix or it will be fixed on the next version of the OS.

Bad news! My son’s pi-top3 also has the black screen problem.
And this when I installed his freshly bought pulse pi. If you disconnect the accessory. Boot OK and normal use.
So I look for a concern about the versions of pitopos above the C712 version.
Same observation with his device, everything works perfectly with Raspberry OS.

@bu3304 Do you mean that after the pi-top Pulse was plugged in you started having these issues on your son’s pi-top?

Yes, that is exactly it

I’ll open a support ticket and we can discuss it further.
Hopefully we can post a solution here when we’ve got one!

Hi @RezIN
Yes, sound okay… rather yes and no : finally the sound is not really ok because
that activates on my son’s pitop, the voice assistant and screen reading. Very annoying at the slightest click on an icon or other interaction.
I am French (country France) and really sorry for my poor English

For screen reader, I found: I deleted ORCA (sudo apt remove orca and killall orca)