pi-topOS Software Update — July 2021

:tada: Time to unplug: go cable-free with your pi-top [4]!

Note: this is an over-the-air update (no new OS image at this time). A new OS image is expected in the coming weeks though!

Since our last OS release (C790), we have released initial support for connecting directly to your pi-top [4] using Wi-Fi!

This is achieved by configuring the Raspberry Pi 4’s onboard wifi chip in your pi-top [4] to support ‘simultaneous AP and Managed Mode’ (Other terms for this are “managed mode AP”, “WiFi client AP mode”, a “micro-AP” or simply “AP-STA”). We are still exploring the best way to communicate this (particularly on the miniscreen), but hopefully it is “intuitive enough” to use while we continue to improve the user experience in this area.

In simple terms, this means that the Raspberry Pi can now broadcast its own Wi-Fi access point as a network that you can connect to for using your pi-top device, at the same time as still being able to connect to a router and access the Internet!

EDIT: In a previous post, this mode was labelled as being like a “wireless repeater”. This is not particularly accurate, as the internet connection is not bridged.

Check out this post discovered by @despots for information on how to bridge the connection if this is something that you want to do. Alternatively, you can express your interest in the GitHub Issue, or even submit a pull request to close it!

:satellite: Tutorial: Remotely access your pi-top [4] from anywhere!

Whatever your favourite way of connecting to your device is (SSH, VNC, web dashboard, etc.), it is now possible to access your pi-top [4] anywhere without cables OR a Wi-Fi router!

First, make sure that your system is up to date.
Then, navigate to settings in the miniscreen menu on your pi-top [4] (usually this means that you need to press the “O” miniscreen button twice).
Scroll down until you get to the access point option:

ap

Press the “O” miniscreen button, and wait until it has been enabled. Once it shows that it is enabled (check for the tick!), navigate back to the system information widgets (press the “X” miniscreen button twice), and scroll down to the Access Point page:

ap_title ap_info

If everything worked correctly, this page will update to show you the connection information. Use this information to connect to your pi-top’s Wi-Fi network!

Hint: the network name will be the same as your device (usually pi-top, pi-top-1, etc.) and the passphrase is written on the miniscreen page (another hint: it’s probably pi-top1234).

Screenshot 2021-07-14 at 15.59.34

:memo: Things To Note

How does it work?

In this configuration, we create a virtual network interface and add it as the AP to the physical wlan0 device. This virtual interface is used by several of the services needed to operate a software access point. pi-topOS manages these configurations in the background for you. Check out this repository for more information.

Network settings: Proceed with some caution!

This is a new feature, and has potential for issues to occur - particularly if you are intending to do anything with the on-device networking yourself. It is strongly advised that you do not use a direct Wi-Fi connection unless you need it, or are willing to accept possible wireless networking hiccups.

Conclusion / Looking To The Future :eyes:: :globe_with_meridians: Everything possible via your web browser!

This is the start of some big changes to how users will interact with their pi-top [4]s.

With this new ability to connect to a pi-top [4] at any time from any device which supports the connection protocol (SSH, VNC, etc.), we are now working to offer this as a primary method for accessing the device to complete the OS setup process - keep an eye out for this in the coming weeks!

As well as this, we are evaluating how to offer a browser-based interface for terminal and desktop access, which will remove the need for any additional software on your device - no terminals, no VNC clients! We believe that this is a significant user interaction improvement, which helps to address a lot of the issues that new users have with using Raspberry Pis (not just with pi-tops).

For now, if you want to do that, check out the Apache Foundation’s guacamole application - experienced users only!

Anyway, we think that this is a significant improvement for pi-topOS, but what do you think? Give it a go and let us know!

3 Likes

Exciting stuff! When you say “wireless repeater”, does that mean the internet connection can be shared (bridged) from the pi-top to other devices connected to it’s AP?

it should be possible! Right now, the connection isn’t bridged though. I will update the original post as that is slightly misleading…

How do you change the WiFi password to something more secure?

Ensure AP is off, then write AP_PASSWORD=password into /etc/default/wifi-ap-sta before enabling again!

Is there a simple way to share the internet connection on wlan0 to wlan_ap0?

Edit: I successfully bridged the connection following this guide.

Just to clarify a few things:

The only relevant sections in the guide are

  • Configuring your WiFi Adapters
  • Install iptables-persistent
  • Adding/Configuring NAT

The interface names need to be adapted

  • wlan0 —> wlan_ap0
  • wlan1 —> wlan0

After doing these, dhcpcd was not running properly on boot by systemd. The solution is to move added configurations in /etc/network/interfaces to a text file in /etc/network/interface.d.

I know this might sound a bit dum but can you change the wifi name?
cus everytime I do it it keeps overwriting its self back to what it was

also the change password for wif AP sta doesn’t work
it still uses the original pss