Raspberry Pi 4 + pi-top1/pi-topCEED

This is a question we get the most often through the support tickets. When the Pi foundation brought out the Raspberry Pi 4, they swapped one of the Dual Stack USBs and the ethernet port, which allowed them to add USB 3.0 but limited us.

We’ve had users send us messages on social media show how they’ve got their pi-top1 and pi-topCEED working with the Raspberry Pi 4 (Kudos to the maker community for being awesome as always :raised_hands:t4: ). They’ve usually backpowerd the Raspberry Pi through their 40pin connector and then grabbed a microHDMI - HDMI adapter et voila!

The pi-top[3] unfortuantely has some mechanical issues, the HDMI port gets in the way of connecting a microHDMI device through to the pi-top Hub and the Ethernet port gets in the way of connecting the USB ports to our keyboard and internal USB Port. All of this means we would need to do a redesign of our pi-top [3] Hardware which costs a lot of money. We’re aware of how frustarting this is for those of you that helped support us during the pi-top[3] days. Though for the moment, the Raspberry Pi 4 cannot go into the pi-top[3].

Here’s one of our community members from Twitter that managed to get a Raspberry Pi 4 inside the pi-topCEED and it looks awesome!

1 Like

I have an early generation Pi-Top CEED. I was a crowd funder. I had forgotten that the native resolution on these units is 1366x768.Support kindly reminded me of that fact.

In order to get Pi-TopOS working I had to do 2 things:

  1. In /boot/config.txt, add the following line:

hdmi_cvt=1366 768 60 3 0 0 1

  1. The HDMI needs to be plugged into the connector farthest connector from the power supply connector. Pi-Top OS has that port labeled as HDMI-1 and the near port as HDMI-2.

I am occasionally having trouble with the screen defaulting back to 1920x1080 and not coming up, but I can change that by going in through VNC and changing it in screen settings. I’ll update if I have any more permanent fixes.

I disabled VNC and I am no longer having any problems. I tried a bunch of settings and could not get VNC to respect a resolution of 1366x768 so I sent it packing.

I’ve also picked up this connector for HDMI: https://smile.amazon.com/gp/product/B01EQC3464/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1