RPI model mismatch

I have recently replaced a Pi 3B by a 3B+ in my pi-top [3]. Firstly I put the same SD card and noticed that the OS still showed that the board was a Pi 3B. Then I reflashed the SD card (latest OS version November 2023) with the same result. For instance Wifi 5Mhz is not available. Any suggestion?


Hi elxose,

I did the same thing a few months back, replaced the 3B with a 3B+ and swapped the microSD card into the new board to get a little more speed from the green monster. My 5GHz wifi is working fine however. I haven’t reflashed, but have ‘updated’ via the OS menu item which hasn’t stopped my 5GHz wifi working. According to my “About” screen, I’m running build 2023-05-23 number 25.

If you run a cat /proc/cpuinfo | grep "Model" does it report a Raspberry Pi 3 Model B Plus Rev 1.4? Have you tried the 3B+ with standard raspian or kali connected to a keyboard, mouse, video and power, without using the Pi-Top3 to ensure you have the right board?

Hi keigraider,

I installed an RPI OS with the same results, then I dismounted the Raspberry Pi and saw that it was actually a model B V1.2, but one with a metal heat spreader over the CPU chip, which I didn´t know that even existed. https://forums.raspberrypi.com/viewtopic.php?t=269827.
Thanks a lot for you interest.

All good mate,

I’m glad you worked it out before going insane :slight_smile:
I can’t say I have seen one of those 1.2 type in my collection of Pi’s. If you can find the 3B+, it is a little faster than the original. The 5GHz networking speed is welcomed, but I can’t say I have ever used the ‘gigabit’ lan as yet.