Sense Hat Issues - rainbow LEDs stay on and Sense Hat is not programmable

I have a classroom set of pi-top CEEDs. I use pi-topPROTO boards to connect Sense Hats. Some of the CEEDs are working fine with this, but around half of the Sense Hats don’t work. The Sense Hat lights up on boot up, but the rainbow LEDs don’t turn off when boot up completes and it stays on the rainbow LEDs Then my students are not able to code the Sense Hats. It just sits there useless with the rainbow LEDs on. All software has been updated.

Any help on this would be appreciated.

you need to open a terminal (crtl + alt + t) and type:
sudo nano /boot/config.txt
then scroll to the bottom and type:
#for the sense hat
then reboot. It should work fine after that

Thanks DrC, but that didn’t work… Anyone have any more ideas?

what do you get when you type in the terminal
i2cdetect -y 1

getting an error. is there a space at ‘t’ and after ‘y’ ?

yes, the command is i2cdetect then -y then 1

This is what I got (see attached)

any feedback on this??


The device is not being detected. I have only seen this with damaged sense hats.

There are a few things that can be checked:
Can you ensure i2c is enabled?

Enable I2C Interface on the Raspberry Pi - Raspberry Pi Spy (

Try with another i2c device to ensure that the problem is not on the Pi end.

In addition (don’t be insulted), are you confident that the boot/config.txt line was added correctly? Was there a long string of text in that file?

If that fails, it might be time to go shopping.

interestingly enough… the Sense Hat worked on another RPi. That must mean the problem is with the RPi itself, right?

It might be, but not necessarily.

That is why I asked about the boot/config.txt file.
Double check that that is definitely done correctly, and if that doesn’t help, check another i2c device. If that is not detecting, you might have an issue.

The last thing that you can try however, is a reinstalling of the OS. That has worked for me before.