[SOLVED] pi-topSirius Update Error

05/15/2020 @1000 MST - Unable to submit a problem on my Pi-Top [4] using the Support form - when I press Submit the Capcha thing appears I press verify and nothing happens, is Pi-Top [4] folks online??

I have tried every avenue available to a user to submit a question, this is the last one.

Not sure what’s happened though I can create new tickets.Would you like to ask your question here anyway?

Just tried submitting the problem again - no response after the Capcha process. I have tried 3 different browsers to see if it was a browser problem. In the process of rebuilding the SD card , but here is the description of the problem:

Powered up the Pi-Top [4] and it automatically checks for Updates, updates were found, but when I select Preview Updates - nothing happens no terminal window opens nothing is displayed but the desktop. Reboot the system and try it again but select Upgrade Now and the same thing happens, nothing is displayed indicating updates are being installed. I have tried the same process at least 10 times for the last two days.
I powered up my Pi-Top [3] and the check for updates ran automatically, updates were found and I selected Review and the same thing happend as above. Rebooted the Pi-Top [3] and waited for the process to start again, selected Upgrade now and this time a Teminal Window opened and the upgrade started.
I try to make it a practise of updating all my Raspberry Pi’s (6) and Pi-Top’s (2) every month, but this time the Pi-Top [4] is not updating. I know I can download a fresh install from you and rebuild the SD card, but this process is time consuming and a pain.
I enjoy the Pi-Top’s so much more than playing with a barebones raspberry pi. Any suggestions you might have would be appreciated.

Thank you

Re-Imaged the SD card and started the Pi-Top{4), ran through the get started process, even though this process indicated it was performing an update - nothing appeared on the display that it was being done. After getting all setup, I initiated a Check for Updates. Updates were found but when I selected Review or Uprade Now - nothing happens that indicates and update was being installed. Same problem as before! Has the update process changed for the Pi-Top[4] where no terminal window appears?

Tried the update process again - no Joy! Tried submitting a triouble report using the support form still doesn’t work. Tried 3 different browsers on my Windows 10 system (Edge, Chrome and Firefox) none worked. Powered up my Pi-Top[4] and was successful in submitting a Support Form.

I find this to be interesting but it opens up a whole lot more questions. I use the Windows 10 PC, becausse it’s faster than the Pi-Top[4] and my email is on my PC. Oh well, maybe now I’ll get a response to the original problem as submitting to this forum has not been productive in receiving any answer to the problem.

Hi @Korbendallaz. There’s a guide on the Knowledgebase related to updating errors. Could you have a look a this page and let me know what happens?

Hey RezN, I typed in the code you suggested on 5/19/2020 (the saame code that is in the knowledge base). This morning I powered on my Pi-Top[4] and a system update started, there were updates and the update process worked as it has before.

Thank you for you assistance