Very poor text resolution

when i open the firefox browser and i navigate to some forums, i get a very, very poor text resolution, it’s nearly impossible to read the text. How i can fix this?
… btw i’m using a 7" capacitive LCD touch screen with 1024x600 resolution from Waveshare.

What browser are you using? You could either just zoom in, or try to see if there are any accessibility features that can change text sizes

Have you tried other browsers to eliminate possible rendering issues with Firefox?

it’s with every browser or windows, and if i change the resolution in the display settings from 1920x1080 into smaller resolutions i can read the text, though than the windows are so big that i can not overview them and the task bar is disappearing. it seems that there is not any matching setting for my 1024x600 screen.

could this the reason why i am not able to get the right resolution? (if i did not do this?!)
4) After the image has finished writing, open the config.txt file in the root directory of the TF card, add the following code at the end of config.txt, then save and quit the TF card safely.

max_usb_current=1 hdmi_group=2 hdmi_mode=87 hdmi_cvt 800 480 60 6 0 0 0 hdmi_drive=1

  1. Insert the TF card into the Raspberry Pi

You can always try this now to test? No need to use a computer as you can do this directly on the Pi, just type:

sudo nano /boot/config.txt

into terminal and add the correct settings there

1 Like

sorry i am a absolut rookie about linux.
when i type in what you have writen in your message, it open ups a terminal named GNU nano 3.2
…though there is no text???
do i have to just type in the code?

… now typed in again sudo nano /boot/config.txt
and i get the message i shouldn’t edit pt config settings
… what now?

Nano is a terminal based text editor like note pad in windows.

Use the arrow keys to navigate

Once you have entered the lines press ctrl + s to save then ctrl + x to exit to the terminal.

Any edits to the /boot/config.txt will need a reboot

1 Like

:rofl: i did it … i typed in the code and it is now worser than ever … taskbar not visible, main menue not visible, cursor is working in the wrong directions left is down, up is left … without seeing the taskbar it is impossible to open the terminal (well i can do “blindfold”, but than open up everything, but not that i wanted)

is there any way to undo my last step? what when i take the sd card and put into EeePc with win10 pro, is it there possible to undo it? I typed in this code:
hdmi_cvt 800 480 60 6 0 0 0

well i need a break, a storm is coming in and the battery need to recharge … i am hoping for help … (get a computer they said, it makes life easier they said😂)

Sorry for the delay, I just got home from work, once I have sorted out the dog I will post screenshots and step by step for you

On windows, insert your memory card into the PC using a card reader and you chould get a drive showing labeled “boot” in there look for the file config.txt

open the config.txt (please note that the config.txt os not from a pi-topOS image, was the only card i had quickly to hand)

Make your changes and save the file. Safely remove the memory card and plug it into your pi-top[4] again and boot as normal

1 Like

would it be possible to post an image of the display?

The link to the product appears to be the wrong one. you stated that its a Waveshare 7" screen with a resolution of 1024x600, the one you linked to is 800x480 so the settings you tried would have been incorrect

If the display has capasitive touch then i believe its this one

Which means that the settings you need in the /boot/config.txt are as follows

hdmi_cvt 1024 600 60 6 0 0 0

also please note as per the documentation

If you use the LCD with Raspberry Pi 4B, you need to remove line dtoverlay=vc4-fkms-V3D

after all that, in the terminal you need to run the following commands to get the touch working

git clone 
cd LCD-show/
chmod +x LCD7-1024x600-show

to set the screen orientation check out this


do i have to delete the complete line or just dtoverlay=vc4-fkms-V3D?

…and at the just

…without typing a # before?20210527_191824|690x310

yes, it’s this display, though the touch screen is working.

All you need to do is put a # at the start of the line to comment it out, the system will ignore that line of code

like that?

the lineyou have as max_usb:current=1 should not need commented out (no #) also there is a typing mistake it should be max_usb_current=1 you just need to comment out the line dtoverlay=vc4-fkms-V3D like this #dtoverlay=vc4-fkms-V3D and add the other 4 lines without the #

hdmi_cvt 1024 600 60 6 0 0 0
1 Like

oh yes, you are right. thanks so much!