Vnc opens infinite windows

I connected vnc to pi-top with wifi.
Today, when I log in, vnc opens infinte windows.
How can I stop it? should I do the configuaration again or can I fix it?

I’m not sure what you mean by infinite windows, but it sounds like your vnc session startup or a login script is looping.

Probably, the best way to stop it is to connect into the pi using ssh (or putty, from windows), run raspi-config from the command line, disable vnc, the re-enable it.

Another option is to directly connect a keyboard, monitor and mouse to the pi, re-boot, and see if the default GUI comes up and is behaving properly.

I’m assuming you are using REAL vncviewer to connect to the REAL vnc server already integrated into pi-top os. Don’t try mixing and matching different vnc implementations - just stick with REAL until you get it stabilized.

You are right: it loops at start up and the result is the following:

I will try your suggestion.
Thanks, Silvano

I was looking at the above vnc screen image you posted, and it looks like maybe you tried to vnc connect to yourself on the same platform, which could cause the infinite window shown. You should be connecting from a different platform using the vnc viewer app.
Also, it is a good idea to setup inbound ssh support so you have an alternate way to get into the pi and kill any misbehaving applications.
I run realvnc server on two RPi4b servers headless (no keyboard, video or mouse connected) over wifi. I typically connect from a windows 10 system using the free realvnc viewer or putty for ssh access.
The only strangeness I encountered using real vnc server on the rpi were two items:

  1. The vnc session would go stale (disconnect) after an hour of inactivity. I discovered this was due to an inactivity timeout set in the server, which can be remedied by changing the setting in the server (click on the vnc icon on the desktop, go into settings, change the timeout to something longer, or disable it).
  2. VNC would not be available after restarting the pi. I found this was due to rebooting the pi without first exiting an active vnc client session. Always use the real vnc viewer exit button to terminate the session. To fix vnc server so it will work again, use the raspi config command line tool to re-activate vnc.

I hope this helps.