1st Boot up issue with screen connection

I’ve just received the Pi-Top 4 and on connecting to my laptop for the first time the pi-top screen shows an animation of the pi-top on the left and alternating images of a laptop and a monitor on the right.
I assume it is telling me to connect to one.
I am connected to my laptop which is a new HP envy laptop.
I’m using the supplied cable from the laptop to the cable connector on the pi-top.
Any ideas what is wrong?
Regards, Kevin.

Hi @TheBernician (also a great name), are you using the USB-A Adapter to connect to the laptop as well? Lastly do you have VNC Viewer downloaded and havve you tried connecting to the IP Address?
You can find a full list of instructions here

Hi everybody

I have the same problem always shows only laptop or monitor.
No matter if I connect to laptop or monitor.
The operating elements on the Pi-top 4 cannot be selected.
Can someone tell me what I am doing wrong.
Thanks

Hey everyone,

I’ve encountered this problem one other time. For me, the solution was to turn my pi-top off, connect it to a monitor via the cable, power it back up, and it would work. I would then go through setup process. Every time I connected to my monitor or my laptop after that, it worked.

If that doesn’t work, I suggest re-flashing your SD card with the latest OS:

And then try the previously mentioned method.

Hi everybody,
I have a similar problem, with the difference that I want to connect to a monitor (TV) via HDMI.
It starts normally on the small pi-top screen [4], and on the HDMI monitor you initially see a multicolored image (in just 2 seconds), then you have no signal to display. Meanwhile, on the small pi-top screen [4], you can see an image / drawing requesting connection to a Pc or Laptop.
I followed all the steps to connect and I have the latest version of OS installed on the Card.
What is missing for everything to go well? So I want to connect to a monitor via HDMI and I don’t want to connect to the PC via VNC.
I appreciate help in solving.
My thanks in advance.

Hi @agapieme, a few questions:

  1. What’s the resolution of your HDMI monitor?

  2. Have you ever used that monitor before with a Raspberry Pi?

  3. Do you have a pi-top [4] Display Cable or are you using micro HDMI?

  4. Did you buy a pi-top [4] DIY Edtion?

I’m wondering if it’s an issue with the pi-top [4] onboarding process, would it be possible to go through the onboarding steps over VNC first until you reach the desktop? You’ll be able to refresh the HDMI output from there too (using the mini OLED screen) and we can do more diagnosis if you have SSH or VNC access to the pi-top whilst it’s plugged into the TV you are trying to make work.

Did you buy a pi-top [4] DIY Edtion?

I’m wondering if it’s an issue with the pi-top [4] onboarding process, would it be possible to go through the onboarding steps over VNC first until you reach the desktop? You’ll be able to refresh the HDMI output from there too (using the mini OLED screen) and we can do more diagnosis if you have SSH or VNC access to the pi-top whilst it’s plugged into the TV you are trying to make work .

Hi @duwudi

First I want to thank you for having responded to my call for help.
Now I will answer your questions:
Question: What’s the resolution of your HDMI monitor?
Response: 1024 x 768 60Hz;

Question: Have you ever used that monitor before with a Raspberry Pi?
Answer: Yes, it is the monitor that I have always used with RaspBerry Pi (not only the one that is now installed on the pi-top [4], as well as other Raspberry Pi);

Question: Do you have a pi-top [4] Display Cable or are you using micro HDMI?
Answer: First I used a micro HDMI and then I used (and use) the pi-top [4] Display Cable (I bought this on purpose thinking that the cause of the issue was for not using it);

Question: Did you buy a pi-top [4] DIY Edtion?
Answer: Yes

I have been doing several steps to find out what might be the source of the issue. One of those steps was to connect the other Monitor HDMI (TV), and this one already worked. The difference with this monitor is that the resolution is 1360 x 768. So the issue is the Monitor. I think there are some settings to modify in Boot (maybe in the Config.txt file). Will be?

ok thanks for the detailed response! Try the following settings in config.txt:

hdmi_group=2
hdmi_mode=16

I got these from here - if it doesn’t work let me know!

Hi @duwudi
Thank you again for your kindness in helping with such a quick response.
Yesterday, so before receiving this last help, I after several unsuccessful attempts, until I chose to use parameters from another config.txt from another Card installed on another RaspBerry 4 (without being installed on a pi-Top [4 ]). therefore the following setings:

# ////////////////////////////////
# AGAPIEME _ HDMI configuration /
# ///////////////////////////////

hdmi_force_hotplug = 1
hdmi_drive = 2
hdmi_safe = 1
config_hdmi_boost = 4
hdmi_group = 2
hdmi_mode = 4
disable_overscan = 0
overscan_left = 24
overscan_right = 24
overscan_top = 24
overscan_bottom = 24

… and so the monitor worked :grinning:, with both cable, the green cable (the pi-top cable) and the mini HDMI installed on the second port.

However, as an old computer technician :crazy_face: :face_with_monocle:, I didn’t want to stop here. So I wanted to try to find out where the cause was, or rather, the origin of the issue. And for that, what did I do? I went back to the original configuration of Config.txt, putting back the previous parameters, to figure out which parameter would be affecting the issue.
Therefore the following (the originals):
# /////////////////////
# HDMI configuration /
# /////////////////////
# Force HDMI out - allow VNC without a display attached
hdmi_force_hotplug: 1 = 1
[all]
# Prevent black border of unused pixels
disable_overscan = 1
# Enable sound over HDMI
hdmi_drive = 2
# Allow HDMI display to go into low-power mode when idle
hdmi_blanking = 1
# Uncomment if you get no picture on HDMI for a default “safe” mode
hdmi_safe = 1
# Uncomment to increase signal to HDMI, if you have interference, blanking, or
# in the display
# config_hdmi_boost = 7

What was my amazement :flushed:, when I would expect the monitor to not work, as it was before my modification, it did.
My dear … miracle? :astonished: I don’t know … but it is working without any problem with the initial config.txt, so without my modifications. What will have happened? :roll_eyes: It is certainly not because we are in the Halloween period! :jack_o_lantern:
I repeat, what will have happened? I only see the possibility that my parameters have affected some other boot file.
What do you think? :shushing_face: :thinking:
Once again, I thank you for your attention. :+1:
Regards

It’s a Halloween miracle! :jack_o_lantern:

However, I did notice this:

hdmi_safe = 1

which could be the culprit, that’s commented out by default on pi-topOS