HAT error message with Raspberry Pi OS "Bullseye"


I am using a pi-top [3] with a pi-topPROTO+ connected to the pi-topHUB v2 and a pi-topPULSE connected to the pi-topPROTO+.

Yesterday I installed a fresh Raspberry Pi OS “Bullseye” to a SD card, which runs very well and fast on the RPi3 B+. I included the pi-top Sirius repository as described at https://knowledgebase.pi-top.com/knowledge/pi-top-and-raspberry-pi-os to get support for the pi-top features in Bullseye.
It seems, that a lot changed since my last installation of the pi-top stuff on a Raspberry Pi OS, all seems to concentrate on the “pt-device-manager” which seems to handle all the pi-top peripherals now.
I installed it and the battery symbol appears and the pi-topPULSE speaker seems to work fine as HDMI audio output.

But immediately after the GUI loads, I get an error message in the upper right corner of the desktop:

“Failed to load HAT overlay”
“dterror: not a valid FDT - err -9”

I am quite sure, it has to do with the pi-topPULSE, because it is (as far as I know) the only device inside my pi-top which contains a HAT eeprom. Is there a dtb-file missing for the pi-topPULSE?

Any ideas how to fix this?

Thank you in advance.

Regards, Thorsten

Hi @dl9sec
Could you send a screenshot of the error you get please?

When installing the pi-top PULSE, you would normally have to wait to install the pi-top packages (or use pi-topOS) and then plug in the pi-top PULSE. When the device is plugged in, you should be prompted to restart the device. Do you remember seeing any notifications?

Could you go into the terminal and try the command
sudo apt-get install pt-pulse

Look forward to hearing from you.

Hi @RezIN,

thanks for the reply.
I am aware of how to install the pi-top stuff on a Rasperry Pi OS “Buster” which was running here for about two years without problems or warnings/errors (maybe with a lot older version of pt-device-manager).

This is the message:

As I already told, I followed the instructions from the pi-top FAQ. I installed the pt-device-manager (4.1.4) as instructed. If the pt-device-manager is installed, the “pt-pulse” (and other “pt-…”-stuff) can not be installed.

As you can see with “sudo apt-cache depends pt-device-manager”, “pt-pulse” is replaced by “pt-device-manager”:

# sudo apt-cache depends pt-device-manager
Hängt ab von: <python3:any>
Hängt ab von: alsa-utils
Hängt ab von: debianutils
Hängt ab von: python3-pitopcommon
Hängt ab von: python3-systemd
Hängt ab von: python3-zmq
Hängt ab von: python3-smbus
Hängt ab von: python3-spidev
Hängt ab von: raspi-config
Kollidiert mit: pt-hub
Kollidiert mit: pt-pma
Kollidiert mit: pt-pulse
Kollidiert mit: pt-speaker
Kollidiert mit: python3-pt-hub-v1
Kollidiert mit: python3-pt-hub-v2
Kollidiert mit: python3-pt-hub-v3
Kollidiert mit: python3-pt-pulse
Kollidiert mit: python3-pt-speaker
Beschädigt: pt-os-mods
Schlägt vor: python3-pitop
Schlägt vor: pt-notifications
Schlägt vor: xprintidle
Ersetzt: pt-hub
Ersetzt: pt-os-mods
Ersetzt: pt-pma
Ersetzt: pt-pulse
Ersetzt: pt-speaker
Ersetzt: python3-pt-hub-v1
Ersetzt: python3-pt-hub-v2
Ersetzt: python3-pt-hub-v3
Ersetzt: python3-pt-pulse
Ersetzt: python3-pt-speaker

Explanation: “Hängt ab von” means “Depends on”, “Kollidiert” means “Collides with”, “Beschädigt” means “Corrupts”, “Schlägt vor” means “Suggests”, Ersetzt" means “Replaces”.

So I assume, that “pt-device-manager” includes now the functionality of “pt-pulse”, but seems to handle the HAT eeprom a bit different or “Bullseye” does things different now…don’t know.

Having the same issue. Same hardware and os

Any progress or workarounds discovered?


unfortunately no.

It seems, that the pi-top guys only supporting their latest stuff and pi-topOS… :frowning:

Have you tried it on a Pi-4?
It’s looking like either a hardware issue or an issue with Buster. I have a Pi-4 on order just to troubleshoot.

No, that doesn’t make sense for me, the pi-top [3] can only hold a Pi3…

Hi, I’m a newbie to Pi, finding my way around. I get the same error at boot up and was searching for help when I saw your thread.
I don’t have a pi-top.
I have a Pi 3B+ with a Rainbow HAT on it.
The error doesn’t seem to cause me any problems with the simple Python programmes I’m playing with (yet).
I hope you find the solution.