Keep settings between boots

I am using my pi-top[4] with a 4k monitor as well as the pi-top screen. It works well. But…

I am also trying (and failing) to ping local hosts. I can if I change /etc/resolv.conf to put my gateway first in the list. But…

When I change the above settings and reboot, the changes I have made to the config files are removed and returned to some ‘default’.

I suspect this is something to do with ‘protecting’ the [4] when used in the classroom. However, for us normal people, this is incredible annoying!

How can I make config changes like I do on my other (few dozen) Pis? I know I can replace the OS with Raspbian, but I’d rather stay with Sirius as it has support for all the add-ons I have (screen/keyboard/baseplates etc).

Thanks

Tim

@GeekyTim This sounds like it may be related to the problem here, which I am suffering, and trying to solve. Try appending .local to your named device, as in ping other-device.local to see if that helps your problem.

JimT

Nope - that does not work either. I’ve found where the Pi-Top settings are and will try changing those so the Pi uses the ones I want!

Thanks for trying…

JimT

I know what the issue is, and have hopefully solved it. Will see on the next boot.

I just need to find a way to get the pi-top to remember screen resolutions.

@GeekyTim Most of my PIs run headless, are connected to via VLC, and I have had this problem off and on. Here is how I deal with it.

  1. ‘Main Menu/Preferences/Main Menu Editor’.
  2. Select ‘Preferences’ in the left window, near the bottom.
  3. In the right window, check ‘Display Settings’ and click ‘OK’.
  4. Back to the 'Main Menu/Preferences/Display Settings/.
  5. In the my Pi-Top case, I select ‘1920x1080_vnc’, and click ‘Save’.

JimT