Pi-Top [4] shuts down when an OS other than pi-topOS is used

Hi there!
About three months ago, I stumbled upon an issue after the assembly which wasn’t that grave back then but now it hinders me from trying out other operating systems.

So I boot up any operating system (other than pi-topOS) from an SD card.
The [4] logo animation keeps looping as usual and everything else works fine.
After a minute has passed, this warning appears (which was shown in this thread before).


Once about 10 seconds have passed, the pi-top shuts down.
It doesn’t matter if an SD card has been inserted or not and it switches off even after e.g. Raspbian has fully booted up.

Therefore, I decided to take a proper look inside.
The silver connector to the Mezzanine PCB fits snugly and seems to have no damaged pins.
The PCB itself is connected to all GPIO pins and they work fine with accessories like for example the Sense HAT.
Looking underneath it, the ribbon cables for CSI/DSI are also properly connected.

For some reason that problem solves itself when using pi-topOS.
The mentioned warning does appear, however it doesn’t shut down the pi-top afterwards.
After the desktop shows up, the OLED screen and its monitoring works like a charm.

Additional info:

  • I’m using the DIY Edition with the 8GB version (Rev 1.4) - the SD card is a 128GB model, formatted to FAT32. Images were flashed with the Raspberry Pi Imager.
  • I am pretty sure that it can’t be a corrupt SD card, as the same card works fine with the latest release of pi-topOS.
  • I have also tried to reset the MCU by pressing the hidden switch under the gold connectors, with no success.

Thanks in advance!

That’s odd behaviour as I personally have a raspberry pi OS image without the SDK installed and have no issues and the SDK can be installed on the 32bit version without issue.

Maybe @duwudi or @pi-topMIKE or @wil can help ya out here

Do you have the USB plug correctly installed in the pi’s USB port? Our MCU uses the RPi’s 5V to know when the power should be cut during a normal shutdown. Although since the shutdown signal was never triggered, I’m surprised this is happening.

Also try updating the EEPROM as per here - this isn’t supposed to be necessary on 8GB version but worth a try

Good morning!

I have checked the USB plug, it’s inserted correctly in the bottom left port.
I also have updated successfully the EEPROM with that method.

Now it seems that I can’t get past the rainbow splash screen on my pi-topOS and it does shut down after a minute.
The former issue remains the same (however, it can get past the rainbow splash screen) with the other SD cards.

Hmm I’m really not sure what’s going on here - I hate to suggest it but can you try re-flashing the SD card? Also are you sure the Raspberry Pi works properly when not in a pi-top [4]?

The Raspberry Pi works fine outside of the pi-top and all of my SD cards boot without any issues.
Unfortunately, re-flashing the OS didn’t solve the problem either.

Last thing I could guess is that the pi-top unit might be broken, but I can’t take a look inside without voiding the warranty.

@kantenkratzer any update on this? Apologies for not responding. Maybe we can get you another unit to test and see if the same thing occurs, might be able to rule options out that way

i’ve got the same issue, after i diassembled the pi top today, to run the raspberry 4 alone (same display, original raspberry power supply) it is not working anymore and as i assembled the pi top back again i get the same warning and the pi top doesn’t boot up anymore. it does not boot the pi top os or the raspberrys noob. (man, i am so tyried about all that)

Good evening, sorry for the late response.
Nothing has changed positively so far, but I have found something odd on my pi-top board which I’d like to share.
So there’s this USB connector on the bottom left side of the unit that connects the Raspberry Pi with the pi-top via the USB plug. As you can see in the picture down below, the connector looks quite off to me.

This could be most likely the cause of the problem, but I’m not sure if this was damaged during the first assembly or already missing.

@Itchy: May I ask you to check your unit for this port as well?

nope, the hardware seems to be okay, i replaced the usb connector with a spare part wich came within the package, though nothing changed. well, i just disassambled the pi top once to run the raspberry in another case, this should stand the pi top i guess, especially when the pi top was build to work for robotics and kids.

the raspberry doesn’t even work anymore disassambled from the pi top, not with the original noob sd card, not with flashed sd card with the pi top os on it.

@kantenkratzer yep that definitely looks like it has been damaged somehow as the connector is missing - please contact support@pi-top.com to get a replacement :+1:

I had the same problem. It could issue with the OS or the sd card might be cracked. The sd crack will be very small but look very carefully to see if there is a crack.

I fixed it but replacing a micro sd and reinstalling the OS

Hope this helps!