Pi-Top4 does no boot

Hi!,
When I try to start my pi-top [4], after several months of inactivity, the system does not boot. The display shows “4” and after a while, this image appears. I have interpreted that the card is not recognized and I have flased a new SD memory with Pi-topOS sirius_C781_2020-12-22_04-11-42, but the same problem remains.

Any ideas?

Regards!
IMG_20210310_190740_808|375x500

1 Like

@fernandezjm that’s strange! The image on the OLED appears when pi-topOS is not communicating with the MCU inside the pi-top [4]. This could be a couple of different issues:

  1. SD card is corrupt so the OS is not booting up properly
  2. Communication problem between the Raspberry Pi’s I2C pins and the pi-top [4]

For number 2, you can try popping the lid off the pi-top [4] by uinscrewing the two screws on the bottom (see step 1 here). Once the lid is removed, push down on the silver connector to make sure it has a good connection (see step 10 here).

Have you tried connecting a display to the pi-top or VNCing into it? If the SD card is fine but the problem is related to number 2 then it should still function normally, then at least we know where the problem lies.

Hi @duwudi,
Problem solved, SD card were corrupt as you sugest in issue 1. New card and everything works fine.
Thank you so much.

1 Like