pi-topPULSE is not initialised

Hi,

I recently had need to rebuild one of my Raspberry Pis. It’s a Raspberry Pi 3 Model B running Raspian Buster. I reinstalled my pi-topPULSE, followed the installation instructions but when I try and run the demo code I get the following error:

sudo python3 led-demo.py
[19:24:58.502860 I] Error: pi-topPULSE is not initialised. Call ptpulse.configuration.initialise() ptpulse.configuration.enable_device()

Any help/ideas as to what the root cause may be, and next steps, would be appreciated.

Thxs,
Adrian

1 Like

I’ve got the same problem. The pulse works on my older Pi-top laptop (with a pi 3) but I’ve now connected it directly to the GPIO pins of a pi4 (not in the pi-top laptop) and I get this initialise error too.

Do the python libraries need updating by pi-top or will it not allow use because it’s not in a pi-top chasis??

thx,
Paul

Hey Paul,

Separately I’ve raised a question with support@pi-top.com and will update this thread when an underlying cause is found. I do wonder if I’d benefit from using an older version of Raspian. My previous setup used Jessie whilst the new setup is using Buster.

Thxs,
Adrian

I originally had this problem when I was using the latest version of Buster with some older version of pi-top-setup that I found on GitHub. It recognized the PULSE itself, but not the hub. As a result, it kind of worked, but not well. By adding
ptpulse.configuration.initialise(host_device_id=2)
ptpulse.configuration.enable_device()
to the python scripts near the beginning I was able to get them to work, but they still generated some warnings. Still, it was better than nothing since it got most of the demos working.

After I did a fresh install and followed the instructions in this article in the knowledgebase, everything worked perfectly. I’m a bit annoyed at pi-top for burying this article so deep, but I suppose they’d rather we were using pi-topOS.

What happens when you type pt-devices into the terminal? This is what I get with my working setup:

Devices and peripherals handled by pt-device-manager:
OS release: 5.4.79-v7+
Host device is pi-topCEED
Peripheral pi-topPULSE is currently enabled