Python SDK for Robotics Kit

Received my Robotics Kit Friday morning, reviewed the instructions for building ALEX (I’ll reference him as George). I built George yesterday and reviewed the SDK Documentation. I was becoming frustrated with my Pi-Top[4]'s not responding to the supplied command line interface code. I update my [4]'s every week religiously but the CLI wouldn’t work. So I removed the 32GB card from the DIY[4] 8GB model and reburned the latest image {pi-topOS-sirius_C781_2020-12-22_04-11-42}. This morning I booted up the DIY[4], configured it and tried the same command to see if the SDK was installed - same error Bash: pitop: command not Found. The Command as listed in the Getting Started guide section 1.2 "Checking that the SDK is installed and working is ‘pitop device type’ does not work. I believe there is a typo in the command, I used ‘pi-top device type’ and it works. I was able to check the Pi-top[4] battery with ‘pi-top battery’ etc.

Started my Pi-top[4] 4GB unit that is wired into George and supplied the new command ‘pi-top battery’ and it works as well - don’t have to reburn this unit.

I do believe there is a typo in the instructions where ever a ‘pitop’ command is listed use ‘pi-top’ instead.

@Korbendallaz : look here.

@Korbendallaz sorry about that, I hadn’t gotten round to updating it yet as we were focussed on rolling out a tonne of updates for the robotics kit and it slipped off the radar.

Here’s the PR for the change, let me know if this is the only place you’ve seen this typo. Also, if you spot anything else in the future feel free to create a PR directly for it - you can edit things right from Github so it should be pretty quick :grin:

Where did you find the instructions for building ALEX?
Figured it out when I double checked the box. Was looking on the regular website and Google and couldn’t find it.
Thanks for letting me know - I found it easy enough once I looked in the right place.

@Montbard is where all our product resources are :+1: If you click Robotics Kit you’ll find them there. They are currently under “Additional resources” but we might be changing that to make it a little bit more obvious

Hi Ryan @duwudi, it would be great idea to have a Demo link above the @Additional resources" link. When you’ve spent a short amount of time following the instructions to build the robot, the first thing you want to do is make it do something.

An ideal Demo would be something like: forward 20, stop if obstruction, back same distance, video on, display in console, pan camera, video off.

The demo code would be an introduction for people and the “Additional resources” link will then be less daunting, as you’ve already seen the robot action some code!

Hi @SteveK, great idea! I’ll create a simple lesson on Further with some demo code to run to test everything works.

We have something similar on the first line follower challenge but it doesn’t test all functionality.

We’ve also been working on a controller app for the web that you could connect to with a mobile phone for FPV control of the robot - is that something you think would be useful for checking everything is working after building it?